How To Unlock Folders?

Discussion in 'macOS' started by vjmacaddict, Jul 15, 2005.

  1. vjmacaddict macrumors member

    vjmacaddict

    Joined:
    Jul 8, 2005
    Location:
    California
    #1
    Today I was trying out Freeway and Nvu, and somehow one of the System folders and another folder (and all of the folders within those two major folders) cannot be modified. When I try to drag another file/folder into the restricted folders, a message tells me, "The item .... could not be moved because "Folder" cannot be modified."

    How do I undo this restriction? There are two choices in the message window, one says "Authenticate," and the other says "OK." If I click on "Authenticate," then I can type in my password and complete the action.

    I cannot find any settings to undo this problem! Help please!!!

    -- vjamacaddict, G4 iBook, OS X 10.3.9, Bluetooth
    :confused: :confused:
     
  2. tobefirst macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #2
    Have you tried command-I to "Get Info" on the folder and change the read and write abilities?

    Just a stab in the dark.
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    First, as tobefirst said, you don't have "permission" to write to those folders, which is why you get that dialogue. You can check the permissions for any item using the Get Info window in the Finder.

    Second, if it is the System (or Library) folder at the top level of your startup disk that you're trying to modify, there is a VERY good reason you DON'T have permission to modify them--they are "owned" by the MacOS, and for the most part users shouldn't be messing with them.

    You can override this on a one-time basis using the Finder's "Authenticate" feature (for example, to copy in a Preference Pane so that all users can access it), but you should only use that if you know what you're doing--mucking around in the System folder can break the OS, which is why you don't have permission to modify it.

    A good rule of thumb is that if you don't know what permissions are, then you shouldn't be messing with them or anything that you don't, by default, have permission to modify. If anything basic gets screwed up, using Disk Utility to repair permissions should put it back the way Apple expects and it should be.
     
  4. fladfishey macrumors newbie

    Joined:
    Nov 29, 2007
    #4
    yea how would u "override finder" please tell i am haveing the same prob
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    You'd probably do better to start a new thread rather than replying to one that's two years old, but anyway:

    If you're just trying to move something into (or out of) a folder you don't by default have permissions to do so with, when you try Finder should tell you you need an admin password to override the permissions, and give you the opportunity to do so. If you don't have an admin password for the computer, ask someone who does.

    If you want to modify the permissions of a file (and you know what you're doing), do a 'get info' on the file, go to the permissions section, click the lock and give an admin password, then set it so that you are the owner, and change whatever other settings you like.

    That should be all there is to it.
     
  6. vansouza macrumors 68000

    vansouza

    Joined:
    Mar 28, 2006
    Location:
    West Plains, MO USA Earth
    #6
    Does not have to be a system folder...

    I copied folders from a USB drive to my iMac and then discovered I could not modify the files there, Excel and Word docs. They are fine on the thumb drive but locked on the iMac... what a pain to unlock them... using get info as suggested here... I finally deleted the folder and recopied... I have no clue why it locked in the first place.
     
  7. johner457 macrumors newbie

    Joined:
    May 16, 2009
    #7

    I cant believe it was that simple, THANK YOU
     

Share This Page