How would you stop Mac from automatically unzipping files?

Discussion in 'Mac Basics and Help' started by HalleluYAH, Mar 12, 2009.

  1. macrumors newbie

    May 20, 2007
    I use Mac Tiger 10.4.11 When I download .Zip files, they are automatically unzipped by whichever program I have set as my default "(de)compression-program" on Mac.

    Please tell me what I should do to stop my .Zip files from automatically being unzipped immediately after I download them.
  2. macrumors 6502

    Dec 4, 2008
    You are using Safari?

    Safari > preferences > General > uncheck "Open safe files after downloading"
  3. thread starter macrumors newbie

    May 20, 2007
    How to stop Mac from automatically unzipping files?

    I've been using Firefox only for downloading .Zip files. Do anyone of you know how to stop it from automatically unzipping files?
  4. macrumors 6502a

    Oct 26, 2007
    In Firefox preferences, under Applications, find the file type (PC ZIP?) and click it and set up the option to just dowload the file, or ask you what to do.
  5. thread starter macrumors newbie

    May 20, 2007
    ".ZIP" isn't listed (I scrolled down the "Applications-window"). So what is causing my Mac to automatically Unzip files without my permission?

    Screenshot shows that ".Zip" is not listed in that "Applications-window":

  6. macrumors 601

    Mar 8, 2005
    Austin, TX
    Do a search in that screen's search box for "zip". Mine has "Gnu ZIP" and "PC ZIP", both of which say "Always Ask".
  7. Moderator emeritus


    Aug 16, 2005
    For me, PC Zip is listed one item up from your screen shot, directly above PICT Picture. I also have Stuffit Archive.
  8. viennashade, Nov 19, 2015
    Last edited by a moderator: Nov 19, 2015

    macrumors newbie

    Nov 19, 2015
    I had this problem and I too did not have zip in my list. But finally we figured out that the solution was right there in the dialog that pops up when you go to download a file! Just got new OS installed and that was set at "Open" as the default. (This is Yosemite 10.10.5 but this dialog box has always been there in the previous versions too.) Guess I just never paid any attention to that before because it must not have been set at "Open." So you can check "Do this automatically for files like this from now on." to have it stop asking you, or "Save File," to have it at least keep that as the default box checked from now on. (Or, if you don't get this window, you'll have to first change your Firefox preferences for downloads, temporarily.)

    downloads dialog.png

    I'm sure you have gotten a resolution by now, or are no longer following this thread, but just thought I'd add that for the next person who happens along.

    Attached Files:

Share This Page