How?

Discussion in 'Mac Apps and Mac App Store' started by buzzfgo, Nov 7, 2004.

  1. buzzfgo macrumors member

    buzzfgo

    Joined:
    Sep 9, 2004
    Location:
    Up State NY
    #1
    How can I tell what what driver set I have in OS X? I want to try to install the driver set that came before the latest OS update. As it seems the new update some how killed my video card. Can I go back? I have a ATI 9800 pro.
     
  2. buzzfgo thread starter macrumors member

    buzzfgo

    Joined:
    Sep 9, 2004
    Location:
    Up State NY
  3. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #3
    Go to Apple menu/About This Mac, then press the More Info… button to bring up the System Profiler app. Now click on Extensions under Software in the list. Click on the Loaded table column header to sort out all the ones that are not loaded, then scroll down and find your driver. Mine was listed under "ATIRadeon", although yours may be different and some are pretty cryptic.

    As to how to revert to a previous version, sorry I can't help you with that. Did you try just downloading the older version and installing it? However, the Radeon 9800 Pro is a very, very common card for PowerMacs, so there must be something else wrong with your system, otherwise many people would be complaining about it. Also try searching for and asking your question on macfixit.com, macosxhints.com, or Apple Discussions. There's a lot of very smart people over there. Not that there's not smart people here too, but those sites are more geared specifically towards troubleshooting.
     
  4. beatle888 macrumors 68000

    beatle888

    Joined:
    Feb 3, 2002
    #4
    have you tried going to the ATI webpage to see if you can download a mac driver there? if its just the video card having problems maybe that will work.

    go here http://www.ati.com/support/driver.html and select MacOS. it will take you to the driver download page. they have a 9800 pro and 9800 pro special edition....make sure you know if yours if the special edition or not. i chose the normal 9800 pro selection and they had drivers for jaguar and panther.
     
  5. buzzfgo thread starter macrumors member

    buzzfgo

    Joined:
    Sep 9, 2004
    Location:
    Up State NY
    #5
    OK i fixed it. I had to install the ATI Dispays 4.2.5 over 4.4.1. With 4.4.1 my computer would boot with all the sounds but the screen was black. After installing the old set it works fine.
     

Share This Page