HP printer and VLAN

Discussion in 'Mac OS X Server, Xserve, and Networking' started by cube, Jul 4, 2012.

  1. macrumors G4

    May 10, 2004
    I have the computer and a c309a multifunction in 2 subnets with VLANs. VLAN routing is activated.

    I can ping the printer but the HP setup or HP add printer programs cannot see it.

    Any way to make this work?

  2. thread starter macrumors G4

    May 10, 2004
    I think the problem might be getting Bonjour to work across subnets.

    But even if I give the IP address to the HP configurator, it can't see the printer, even if I can ping it.

    It does work if they are in the same LAN.

    I thought it was maybe a Mac firewall issue, but what I tried didn't work.
  3. macrumors member

    Oct 19, 2010
    Vlans were designed to separate networks so you need routing from and to a different vlan/network. As far as this printer it does not know anything about vlans's it will just get the default network and gateway. On the computer side you can make a static route with proper gateway to be able reach the correct network also it needs to have a link (virtual ethernet) to both networks.
    Last but not least why does this printer needs to be in a different network????
  4. macrumors 601

    Aug 15, 2005
    You might want to re-read the post above yours carefully. Specifically:

    If he can ping it, the routing is fine. ;)

    cube Is it printing or the scan mechanism that isn't working? Mine has a web page I can use to scan individual pages.
  5. thread starter macrumors G4

    May 10, 2004
    I have now put the 2 devices in the same LAN but with netmask
    to see if I can configure it and then move to separate subnets, but it is still not being seen.

    I have now enabled RIP v.1 in both directions, no luck.

    On the Mac called 'foo', nslookup does not find foo.local, foo.local.

    I tried Bonjour Browser and see nothing.

    The LAN router/firewall is set as DNS proxy. DNS server is the DSL router.

    I am not sure what domain name I should give in the LAN configuration, if any, to just have local.

  6. thread starter macrumors G4

    May 10, 2004
    OK, the Mac's mDNSResponder configuration was somehow messed up.
    I could not see the Airport Extreme in the same subnet either.

    So, when placed in the same subnet with the net mask, I could add the printer using HP Utility, but not the HP configurator.

    Now, this mac 'foo' can ping foo.local, but nslookup and dig cannot find foo.local

    I then separated the subnets, and while I can access the printer by IP, I cannot print or use HP Utility. I guess because I cannot even ping printer.local

    I enabled RIP v1 in the router and tweaked pf on the Mac with no success.

    I want the printer in 2 VLANs which are otherwise disconnected. These are port-based VLANs, but they still require a separate subnet for each.
    So I put the printer in its own VLAN, and made its port a member of the other 2.

    But if I cannot get the printer name in .local, it's doomed.
  7. thread starter macrumors G4

    May 10, 2004
    I also tried RIP v.2

    I looked in the manual and it seems this RIP stuff only applies between the wireless and the LAN
  8. macrumors member

    Oct 20, 2008
    If you want Bonjour to work, then you need to configure multicast routing. It doesn't matter if you add the routes by hand or have a routing protocol (which ever) insert the routes for you.
  9. thread starter macrumors G4

    May 10, 2004
    I could add the pinter using the Mac IP dialog.

    But then HP Utility would lose the connection.

    The Mac firewall was blocking ICMP.

    But that's not all, I had to disable UDP flood prevention on the router/firewall.

    But I had not scanner of FAX.

    The HP configurator would still not find the printer by IP, even if on the same subnet.

    Now I found out this software is not compatible with Lion.

    I am now installing the Apple-distributed software to continue.
  10. thread starter macrumors G4

    May 10, 2004
    I did what HP said, and it's the same.

    It seems this stupid multifunction can only be fully utilized with Bonjour.


    Why on the Mac 'foo' can I ping foo.local but not dig or nslookup it?

  11. thread starter macrumors G4

    May 10, 2004
    I tried the dscl hack but it seems it no longer works with this Lion garbage.
  12. macrumors member

    Oct 20, 2008
    This has nothing to do with Lion and it's no garbage.

    Without multicast, Bonjour doesn't work. There is no need for any 'hack'. Look here to learn more about Bonjour: http://en.wikipedia.org/wiki/Bonjour_(software)

    Ping is unicast traffic (ICMP).
  13. thread starter macrumors G4

    May 10, 2004
    Lion is garbage because of the stupid scrollbars, not having Rosetta, and now preventing a simple hack.

    If I could enable multicast routing I would already have done so.
  14. thread starter macrumors G4

    May 10, 2004
    Maybe the firewall could handle mDNS with IPv6, but the printer does not support IPv6.

Share This Page