I can't startup my PowerBook!

Discussion in 'PowerPC Macs' started by michaelltd, Apr 18, 2006.

  1. macrumors regular

    michaelltd

    Joined:
    Mar 30, 2005
    #1
    Hi.

    I got me a problem.

    I have a PowerBook G4 15" 1.5GHz.

    Not too long ago today, I tried turning it on, but instead of hearing the comforting Macintosh chime, I hear three beeping tones and nothing appears on screen. Also the light on the front release button is blinking occationally.

    I've tried resetting the PRAM, holding down control and command with the power button, and even reseting the Power Manager. All to no avail. I have not installed anything new to the PowerBook last time it was working, so I am stumped.

    Any suggestions?
     
  2. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Have you got third party RAM? From memory, three chimes means bad RAM so maybe start by taking individual chips out, where applicable. :)
     
  3. thread starter macrumors regular

    michaelltd

    Joined:
    Mar 30, 2005
    #3
    I haven't installed any extra RAM into my PowerBook. It is the same RAM that the PowerBook shipped with. Could that RAM have gone bad?

    I'll see what I can do about that. I'm not sure if there are two 256 MB of RAM installed or if it is one 512 MB. I'll find out right now though.
     
  4. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    RAM can go bad. Having said that, if you don't feel terribly confident taking it out just yet, then first try starting from the Hardware Test CD that came with the PowerBook and see what that says. Unfortunately, it can't give you a definitive answer because it often can't see the problem at hand, but it may still help.

    If you didn't get a separate test CD, then it is probably incorporated into one of your OSX disks. :)
     
  5. thread starter macrumors regular

    michaelltd

    Joined:
    Mar 30, 2005
    #5
    I tried that a few minutes ago.

    I held down c and turned on the PowerBook. I can hear the disc spinning and it actually fed in the disc when I inserted it before this, but it still chimes and the screen remains blank.

    Gah! And it just had to happen now. >.< I have some college stuff on it that I intended to present this morning at 9 AM. Damn you, Murphy, and your stinkin' law. :p


    EDIT: Oh, also, I can't even check the RAM because I don't have a screwdriver small enough for the screws. I really should get one.... apparently. :)
     
  6. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Okay, just reread your post and noticed it's a 15 inch PowerBook... I hope this doesn't apply. :eek:
     
  7. thread starter macrumors regular

    michaelltd

    Joined:
    Mar 30, 2005
    #7
    It appears that it does. My serial number falls within the range they specified. And it is exactly experiencing the first symptom mentioned.


    Thanks for all the help. I guess I'll send it into Apple to get it fixed.
     
  8. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Yeah, sorry to hear it. Hopefully it'll get fixed/replaced quickly.

    Good luck. :)
     
  9. macrumors 68030

    Supa_Fly

    Joined:
    May 30, 2002
    Location:
    Toronto, Ontario, Canada
    #9
    Nice work Mad Jew!
    Nice quick & efficient; hope they thread op can get a few days reprieve on the project needed in 3mins.
     
  10. macrumors 6502

    Cloudgazer

    Joined:
    Apr 22, 2005
    Location:
    RSA
    #10
    Oh crap, just realised that my pbook's serial number falls within the range specified.
    Thankfully though, I haven't had a single problem.

    But it does scare me, cause I'm gonna add extra RAM in a couple of months.
     

Share This Page