I can't upload anything in Safari

Discussion in 'Mac Apps and Mac App Store' started by alec, Feb 15, 2006.

  1. alec macrumors regular

    Joined:
    Oct 19, 2005
    Location:
    Washington DC
    #1
    Everytime I try to upload anything in Safari, like in Gmail or on Monster, Safari either crashes or I get an error message like this:

    Safari can’t open the page.
    Safari can’t open the page “http://resumes.monstertrak.monster.com/cgi-bin/resumes/resmail.pl”. The error was: “POSIX error: Invalid argument” (NSPOSIXErrorDomain:22) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

    Does anyone have a solution to this?

    Thanks,
    Alec
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Does it work with Shiira? If not (then it's probably webkit), does it work in Firefox/Camino? If not, does it work with Opera?
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #3
    The URL that you posted does not exist on Monster.com. I have an account as a professional and have experienced no problems with Safari.
     
  4. alec thread starter macrumors regular

    Joined:
    Oct 19, 2005
    Location:
    Washington DC
    #4
    Uploading works fine in every other browser, and yes, such a URL does exist on Monster -- it's on Monstertrak.
     
  5. radiantm3 macrumors 65816

    radiantm3

    Joined:
    Oct 16, 2005
    Location:
    San Jose, CA
    #5
    I have the same problem with basecamp. One day safari decided that it doesn't want to upload anymore. So I have to switch to camino when I need to upload something.
     
  6. PlaidHatter macrumors member

    Joined:
    Jul 19, 2005
    #6
    Thought I was the only one having this problem. Hoping someone comes up with a solution. I'm thinking that it is probably related to an extension. What extensions have you installed?
     
  7. radiantm3 macrumors 65816

    radiantm3

    Joined:
    Oct 16, 2005
    Location:
    San Jose, CA
    #7
    I'm using quite a few. Safaristand, saft, pith helmet, and webdev additions.
     
  8. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #8
    I can read. I can also click a link, which does not depend on my ability to read. The link as you posted it does not exist. I tried it in Safari. I tried it in Camino. It does not exist—at least, not to the world outside your Monstrak account. I upload resumes. I also upload letters of recommendation. I have never had a problem uploading files using Safari or any other browser, for that matter.
     
  9. lpshean macrumors regular

    lpshean

    Joined:
    May 30, 2005
    #9
    I'm experiencing the same problem as you are. Its freakin annoying! Have you found any solution yet?
     
  10. PlaidHatter macrumors member

    Joined:
    Jul 19, 2005
    #10
    No solution yet. Just a bunch of people arguing and telling us that we don't have a problem!
     
  11. lpshean macrumors regular

    lpshean

    Joined:
    May 30, 2005
    #11
    Pfft. Oh well.. we'll have to stop uploading stuff then! Thank god its not a problem with downloads or page viewings!
     
  12. PlaidHatter macrumors member

    Joined:
    Jul 19, 2005
    #12
    Solution found!

    Alright folks, I found the solution. You need to go into ~/Library/Caches/ and unlock the Safari directory. Not sure exactly how this can get locked, does anyone else have any idea?
     
  13. miniConvert macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #13
    It's there and works fine, just remove the extra " from the end that vBulletin tacked onto the hyperlink. It's some kind of script anyway so you're not going to see anything in particular. Chill pill.
     
  14. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #14
    Hmm, Safari works for uploading to Facebook... (unlike Camino/Firefox which always fail...) but hey I just use a standard version without plugins as I prefer Camino.
     
  15. lpshean macrumors regular

    lpshean

    Joined:
    May 30, 2005
    #15
    Nah, didnt work! My folders werent locked to begin with. This is getting weirder by the minute. Thanks for trying tho.
     
  16. deller macrumors newbie

    Joined:
    Jan 25, 2007
    #16
    Hi
    I experience the same problems with 10.5 and Safari 3.0. Deleting the cache
    & prefs and disabling the cache didn't help either. Did you find a resolution to
    this problem?

    Thanks
    Andy
     
  17. ravdov macrumors newbie

    Joined:
    Oct 10, 2008
    Location:
    Seattle, WA
    #17
    :mad:

    I can't seem to upload any photos at all when using Safari. Attachment to my emails like picture, songs, etc....nothing. I get an error page. I even tried uploading an icon for this account in Safari - another error page. What's up with this? Any ideas? Thanks!
     

Share This Page