I could see my new external USB hardrive once but i ejected it and now i can't see it

Discussion in 'Macintosh Computers' started by MianW, Dec 1, 2004.

  1. MianW macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #1
    I could see my new external USB hardrive once but i ejected it and now i can't see it anymore even after i restarted my computer and stuff like that. The same thing happened with my usb stick. I can still see it in the system profiler and i tried using disk utility but i don't know how to do it. My computer is a powerbook G4 with mac X 10.3.6
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #2
    Highlight the drive in the left pane in Disk Utility and click the Mount button at the top.
     
  3. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
  4. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #4
    have you tried disconecting the drive and reconnecting?

    disconnect it and repair permissions, then try reconnecting and remounting it
     
  5. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #5
    I tried disconnecting it a hundred times. How do i repair permissions?
     
  6. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #6
    open disk utility, select the volume to repair on the left, and then click repair permissions
     
  7. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #7
    That's the problem the harddisk doesn't show in disk utility
     
  8. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #8
    Can you see it in System Profiler?

    Also, is the drive plugged into the wall?
     
  9. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #9
    Yeah I can and it's also plugged in the wall. please help
     
  10. Mechcozmo macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #10
    Alright, how about a nice long detailed description of the problem... when you eject something that really means that it is safe to remove... I'm a little confused on what your issue is, here.
     
  11. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #11
    my problem is that i would like to use the harddrive but it doesn't show up it only showed up once and now it doesn't anymore
     
  12. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #12
    Try this on your main Hard drive, not the new USB one.
     
  13. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
  14. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #14
    plz help or should i go to a mac store and ask there?
     
  15. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #15
    Patience...my friend...we're trying.

    Another thing to try is create another user, login as that new user and try to connect the drive and see if it will mount or if Disk Utility will see it.
     
  16. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
  17. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #17
    The genius bar sounds like a good idea.

    Good luck.
     
  18. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
  19. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #19
    Whoops...you don't seem have an Apple retail store near you :(

    Every store has a genius bar, where you can ask the experts about all your troubles.

    PS. Learn to use the quote button on the bottom right of every post, helps others figure out who you are talking to.
     
  20. dotnina macrumors 6502a

    Joined:
    Aug 19, 2004
    #20
    I’m having a hard time following this thread. What’s going on exactly? The title makes it sound like you ejected a hard drive, and no longer see it mounted (yes … isn’t this how things are normally)? It seems though, that something else is going on as well. Can you describe what’s going on? If the tips people offer don’t work, explain what didn’t work exactly (ie, if you got an error message, what did the message say, etc.) Thanks.
     
  21. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #21
    I understood it this way.

    He/She plugged in external drive and it mounted the first time.
    He/She "Ejected" drive and it unmounted.


    Now it won't mount again. Sys Profile sees it, but Disk Utility doesn't.
     
  22. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #22
    The first time the drive just showed up on the desktop but now it doesn't and at the disk utility thing i can't select it because it isn't on the list but it does show at the system profiler. The tips didn't work because it still didn't show up. I hope it's clearer now.
     
  23. Champale macrumors member

    Joined:
    Jul 23, 2004
    Location:
    Chicago, USA
    #23
    Disk Warrior

    I've had that happen to me before.

    Usually it's happened when I disconnect the hard drive before actually dragging the icon and ejecting it properly.

    I'm then punished by not being able to see it again.

    Disk Warrior has always been able to 'see' invisible drives that Disk Utility misses.

    But it's kinda expensive if you don't own it already.

    You might want to see if there are other programs out there that will allow you to mount volumes besides Disk Utility.

    Good luck.
     
  24. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
  25. MianW thread starter macrumors newbie

    Joined:
    Dec 1, 2004
    Location:
    Amsterdam
    #25
    Too expensive but what kind of program am i looking for
     

Share This Page