I got the Safari 'Red Text Link' error

Discussion in 'Mac Basics and Help' started by Shotgun OS, Jan 19, 2007.

  1. Shotgun OS macrumors 6502a

    Joined:
    Dec 18, 2006
    Location:
    Ohio
    #1
    On some sites, when I go to certain pages, all the linkable text is bright red. And all clicked links turn a darker red. I've searched about Google and found about this 'error' in Safari.
    link for article

    Now, Im pretty good with computers, but I dont understand what a CSS document is, or anything about HTML (which, from what I understand, seems to be the problem.)

    Can someone explain what a CSS is, and how I might go about fixing this? Safari is my favorite browser, so I would reall not want to switch to a new one because of this.
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    If I read this correctly in my quick scanning, there's nothing you can do fix things from your end...it's a bug in the site's coding and how Safari deals with that bug.

    I don't recall ever having come across this issue...at least not that I thought wasn't intentional. Interesting.
     
  3. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #3
    CSS is a simple script that can control the style of the element in a webpage. So u don't need to do the repeat work of HTML tags again and again and again.
    Of course, right now CSS right now can interact much more with ur operation with elements in the page, but thats beyond my experience.
     
  4. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #4
    I've never heard of it, but it's what WildCowboy said, it's due to a error in the site's CSS, and the way Safari deals with that error. Nothing the user can do except contact the site and tell them.
     
  5. briantology macrumors 6502

    Joined:
    Jun 5, 2006
    #5
    Wow, I encountered that exact same problem today. It's never occurred before, just today (well maybe last night too, I don't remember). I've only seen it on one site, MySpace.
     
  6. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #6
    I'm shocked. :rolleyes: :D
     
  7. briantology macrumors 6502

    Joined:
    Jun 5, 2006
    #7
    Haha, you prolly coulda guessed that without me sayin'
     
  8. Shotgun OS thread starter macrumors 6502a

    Joined:
    Dec 18, 2006
    Location:
    Ohio
    #8
    I got it first there, too...:rolleyes:
    Other sites affect I have gotten so far are just random sites in Google searches....
     
  9. Iggy macrumors regular

    Joined:
    Nov 6, 2003
    Location:
    Bournemouth, UK
    #9
    ARG! It's happened to me too. First on my iMac and then a couple of days later on my iBook. I've only seen it on Myspaz.
     
  10. briantology macrumors 6502

    Joined:
    Jun 5, 2006
    #10
    Is it just recently? Like, in the past week or so?
     
  11. Shotgun OS thread starter macrumors 6502a

    Joined:
    Dec 18, 2006
    Location:
    Ohio
    #11
    yes; happened to me on friday.
    I'm kind of used to it now....still, I hate red text. :/
     
  12. briantology macrumors 6502

    Joined:
    Jun 5, 2006
    #12
    Definitely ugly to see all over a page, oh well...
     
  13. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #13
    I think Myspace must have just f'd up thier style sheets. I've just noticed the red there as well.
     
  14. majorp macrumors 6502

    Joined:
    Nov 28, 2005
    Location:
    UK !!!
  15. AdamL macrumors member

    Joined:
    Aug 4, 2006
    #15
    I'm having this problem too. It's annoying. I've been using FireFox lately anyways.
     
  16. stoid macrumors 601

    stoid

    Joined:
    Feb 17, 2002
    Location:
    So long, and thanks for all the fish!
    #16
  17. Plymouthbreezer macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #17
    Same for me too. It's quite annoying.

    I'm sure we'll see a fix soon enough.
     
  18. Shotgun OS thread starter macrumors 6502a

    Joined:
    Dec 18, 2006
    Location:
    Ohio
    #18
    seems mine is fixed now. is anyone elses fixed?
     

Share This Page