I just installed Vista public beta 2 on my MacBook with BootCamp (help!)

Discussion in 'Mac Basics and Help' started by animefx, Jun 8, 2006.

  1. animefx macrumors regular

    Joined:
    May 10, 2005
    Location:
    Illinois
    #1
    someone already said they were able to get Vista public beta 2 working just fine through BootCamp on their MacBook.

    well, my installation went pretty smoothly (took a long time though) but after the first install and it wanted to reboot, a message comes up saying it couldn't find winloader.exe or winload.exe (I can't remember which) and to either hit ESC (which it just sits there) or to re-run the Vista installer and run the repair startup.

    I ran the install disc again and went to the repair option and choose startup and the Vista installer looked but said it couldn't correct the problem :(

    I'm not sure what to do at this point. If I hold option at start up and choose the Windows partition it will bring up the message that it can't find winload.exe or winloader.exe

    I wonder if I could some how exact this from the ISO on the DVD i burned and manually put it on the folder where its supposed to go? In Mac OS X the partition shows up as "Untitled" right underneath my Macintosh HD, so I'm able to view the files on my windows partition. I'm also able to copy some to my desktop (although I have tried copying files TO the windows partition) so I think it must have formated the drive with FAT32 which is fine.

    Anyway, if you guys can help me with my problem that would be fantastic.

    - Bryan
     
  2. CaptainCaveMann macrumors 68000

    CaptainCaveMann

    Joined:
    Oct 5, 2004
    #2
    And so it begins. :rolleyes:
     
  3. treblah macrumors 65816

    treblah

    Joined:
    Oct 28, 2003
    Location:
    29680
    #3
    Well played. :cool: :rolleyes:

    Did you delete the EFI partition first?
     
  4. animefx thread starter macrumors regular

    Joined:
    May 10, 2005
    Location:
    Illinois
    #4
    No, I wasn't aware I needed to delete a partition... Is the EFI partition the 128 MB one? Should I delete that from within BootCamp? and also, if I was supposed to delete it after one thing and before something else, at what step should I have deleted it?

    Thanks!!

     
  5. animefx thread starter macrumors regular

    Joined:
    May 10, 2005
    Location:
    Illinois
    #5
    I went into the Vista installer and deleted the 200 MB EFI partition, and then I ran the repair on startup and it still wasn't able to fix it.

    Now I'm unable to delete the Vista partition or Run BootCamp assistant so I can start over again. I'm not sure what to do... help! I have a useless Vista taking up 23 gigs of hard drive space that I can't even delete now.

     
  6. grabberslasher macrumors 6502

    Joined:
    Aug 2, 2002
    Location:
    Éire
    #6
    Please refer to my instructions over at http://forums.macrumors.com/showthread.php?p=2500396&posted=1#post2500396

    Remember it's not for the faint of heart, and you really really must know exactly what you're doing to replace the EFI partition.
     

Share This Page