I know Microsoft would bring death to my iBook...

Discussion in 'PowerPC Macs' started by PowerFullMac, Jul 20, 2007.

  1. macrumors 601


    Somethings definatly wrong here, just got a e-mail from my mate saying he got a .doc which is some pages of the new Harry Potter, so I (stupidly) opened it and it crashed M$ Word, so I tryed to use Force Quit but it didnt come up when I used the key combination so I clicked command Q and it worked but I got the spinning beach call so I clicked the power button then Shutdown and everything went but my background then nothing happened for 10 minutes so hold down the power button to turn it off then I press it again and now it wont do anything but show the boot screen with the Apple logo and the spinning please wait thingy. What do I do? Need help I have important stuff on there and its my only computer (using my mates one now) and im only a teenager dont have any money for a new laptop!
  2. macrumors 65816


    Thats what you get for reading spoilers :D .

    This sounds like a stupid windows virus. What kind of mac do you have? Were you in bootcamp or parallels?
  3. macrumors 601


    Wasent in any of 'em I was using the Mac version of Office, or I wouldnt really care 'cos it would just be a virtual system. And its a iBook G3, 900MHz.
  4. Moderator emeritus


    Well if your grammar didn't kill it... then I guess it was inevitable. :(

    How long did you wait at the spinning logo screen? Wait several minutes -- it could be self-correcting disk issues.

    If that doesn't work, then...

    1) press and hold the sequence apple (or command) - option (or alt) - "P" - "R" while booting (e.g. find the keys, get them ready, hit the power button while it's off, and then immediately press and hold the key sequence until you actually get to the screen with the apple logo). Give the boot extra time to finish.

    2) if that doesn't work, hold the power button to turn it off, and now turn it on with Cmd-S instead. It should boot into a text based mode. You will see instructions. You will type

    /sbin/fsck -fy

    Exactly as shown. It should give a bunch of text -- it will take several minutes -- and then eventually either tell you that it succeeded or it failed to repair / verify the disk. If it succeeded, type in

    shutdown -r now

    And then then let the computer try to reboot.

    More details: http://docs.info.apple.com/article.html?artnum=106214
  5. macrumors 6502

    Dude, Harry Potter is a magician. He hosed your 'book, not Bill Gates.
    Seriously, boot in Safe Mode, run something like Onyx, sounds like a rouge cache file.
    Edit: After you do mkrishnan's advice.
  6. macrumors 601


    Thanks ill give it a go then remove M$ Office and install OOo or some other free varient. Or just not try and get Harry Potter the day before it comes out. What a thing to happen a day before your birthday. And sorry for the bad grammer im panicking here!
  7. macrumors 68040


    Sounds like the file you opened had a Macro Virus hidden inside, something which can affect any system running a version of Microsoft Office (a flaw inside Office).
  8. Moderator emeritus


    To be honest, I think that MS Office is very peripherally involved in whatever happened... I have heard hardly any stories of it bringing down the entire OS and causing such a spectacular crash. This might even be the first I've ever heard.

    In terms of what happened, I have no idea why the file crashed your computer, but I suspect that (a) there are no viruses, worms, or other malware involved; (b) that Office didn't "do" anything to your computer. I think what happened is that when the computer went down, the hard drive write state was such that the logical system of the hard drive isn't healthy enough for you to boot (that's what fsck fixes). It happens occasionally on crash.

    The other major possibility is that, quite by random, you stumbled onto a totally unrelated problem, like your logic board going bad, bad memory, etc. I think that's actually far more likely than the possibility that Office really has anything to do with your problem. Even macro viruses don't really do anything that dramatic. They do minor annoying things. I don't think they'd be able to affect a Mac so seriously, even from an admin account, that it would not boot.
  9. macrumors 6502a


    Try a verbose startup to see where its hanging. You'll see a black screen with writing - read it and try make some sense of it. Little clues may emerge on what the problem is

    Hold down cmd-V after you’ve hit the power button (until you see text on the screen).

  10. macrumors member

    You could always just take it to an Authorized Mac Dealer and see if they can figure it out.
  11. macrumors 601


    But before you do that, you should, just in case, back as much of your stuff as possible.

    If you have another mac with Firewire, connect the two together with a firewire cable, then, on your broken mac, restart it holding the 'T' key. This should start it up into 'Target Disk Mode', and will appear on the other mac in a few secs.

    Copy everything you can (except that Happy Potter book ;)), take it to a Apple Dealer, then see what happens.

    Or you can do a reinstall of the OS.
  12. macrumors 65816


    You honestly don't think any sort of malware was involved, when the offending deed was through an email that has spam written all over it. You can't picture "I HAVE READ THE HARRY POTTER BOOK, HERES THE ENDING!!!!!1!!1" in your inbox, even if it is from a trusted source? If it was a virus intended on crashing a PC through office, it very well could have messed with office on the mac, and for some strange reason, done something to his system. I mean, it isn't very likely, but it is not out of the realm of possibility. There is deffinitely something fishy about this...
  13. macrumors 68040


    Exactly the same thing has happened to this user.

    Seems like something's bouncing round at the moment...
  14. macrumors 601


    mkrishnan, just tryed the fsck and it said it repaired some stuff then at the end it said:
    ***REBOOT NOW***
    Then I done that shutdown -r now thingy and it said:
    Shutdown time has arrived.
    And lots of otrher stuff then it rebooted back on to the normal start up screen which ive just been staring at for 10 minutes. So, still not working:confused::(

    The only reason I even opened it was because I thought even if it was a virus it wouldnt effect the good ol' Mac.
  15. macrumors 65816


    Well it shouldn't. I mean mkrishnan is probably right, it was probably a coincidence. A virus or some sort of malware is just the first thing that popped into my head, as it seems so blatantly obvious that something like this is a result of malware in spam emails.

    Maybe this is a sign I have been at work with this damn xp box far too long...
  16. macrumors 601


    Ok, just done that fsck thing again like it said to do on the Apple site mkrishnan linked to and it said that the filesystem of MacOSX (the name of me disk) appears to be OK. Still not working though. Any more help?
  17. Moderator emeritus


    Do you have a system install/restore DVD or CD from which you can boot? If so, try that (hold down c during boot to boot off it).

    Otherwise, try a safe boot by holding down the shift key on boot (this was another one that was on that list)... sorry for the endless list of different key combos to hold on boot. :p

    If that doesn't work, how much memory does your iBook have? Assuming it has a memory module in the user removable slot (under the keyboard), are you comfortable with trying to take it out and seeing if the computer will boot without it? Macs are very sensitive to bad ram, and behave very chaotically (or not at all) if they have bad ram, so the ram is often on our suspect list.
  18. macrumors 601


    Tryed safe mode with no joy, and ill try the RAM thing now.

    EDIT: How would I go about removing the RAM? I open up the keyboard up cant get to it (cant even see it) and cant make sense of what the diagrams are saying.

    ANOTHER EDIT: I dont have the restore disks for Tiger, but I do have them for the version that came with my laptop (10.1 or something) and want to avoid installing that or removing any data from my HD, if possible.
  19. macrumors 601


    Cant anyone help? Do I need to take it to the Genius Bar? Will it cost to repair since I have no warranty as of 3 years ago. Will my HD need to be formatted?
  20. macrumors 65816


    It sounds like you should take this to a genius bar. I don't think they will charge you much if anything just to take a look, though I could be dead wrong. This seems like it is out of your control.
  21. macrumors 601


    Just tryed to start in safe mode again and got a kernel panic! panic: We are hanging here... with sometihng in the background that says I need to hold down my power button.
  22. Moderator emeritus


    If you have a genius bar, yeah, at this point, that is what I would do also. Sorry.
  23. macrumors 6502

    Before taking the computer to have someone look at it you should try to troubleshoot it. No need to go through a trip to an Apple store if it could easily be fixed.

    Start up from the install disks that came with the computer and repair the drive. There may be some errors or corrupt directory that is causing the problem. A simple disk repair could solve your probem.

    Also, reset PMU, PRAM, NVRAM, etc....

    If it boots off the install disks with no problems, then it is likely not to be a hardware issue and no need to take it anywhere. If repairing the drive does not fix it, you could perform an archive and install and that will surely get you going again, unless of course it won't boot off install disk either. If it doesn't boot off the install disk and you have reset the PRAM, PMU, etc.... then take it in to have it looked at.

    This is more than likely a software issue that can be fixed quickly if you follow what I suggested to do.
  24. macrumors 601


    Thing is, my nearest Genius Bar is very long way. My uncle is coming around tomorrow and hes a Mac guru so i'll see what he says. If im lucky he'll fix it.

    PS: Here is a pic

    Wont even turn on now! Nothing! Not even the start up sound or a screen flicker!

    EDIT: Just the battery...

    Put the disk in and started while holding down command-C and it still trys to boot form the HD. How do I reset the PRAM etc.

    Also, I tryed a disk repair and that didnt work.

    I have a I/O error. I started it up in verbose mode and it said it was a I/0 error before it started hanging. Then it shows load task exited by signal (10) about five times.

    Attached Files:

  25. macrumors 65816


    That is a kernal panic. If a restart doesn't clear it up (which obviously is the case), you are going to need a mac genius.

Share This Page