iBook 600mhz interesting problem

Discussion in 'PowerPC Macs' started by teamturbo, Jan 30, 2007.

  1. teamturbo macrumors member

    Jan 30, 2007
    Hi folks,

    I have a G3 PPC 600mhz iBook. Just recently, I've encountered some problems with it. I'll try to explain as best as possible, and if anyone has any thoughts, please let me know and I'll be very grateful.

    I've had some problems with my iBook turning on:

    When I push the power button, nothing happens. I hear a spool up followed by nothing. Kind of like something inside the laptop is spinning up, and then it stops.

    I kind of messed around it and I'm pretty sure this spool up sound is coming from the CD drive. Here's where it gets interesting.

    When I try to turn the computer on and immediately after push the eject CD button, the computer *sometimes* turns on. I pretty much have to try 10 times before the drive opens. Once it does, the computer boots up.

    Anyone know the link between the spool up sound when I try to start the computer & popping the CD drive open? Obviously I don't want to have this fixed professionally as it will cost more than the computer is worth.

    I'm very good at solder tiny chips on mother boards, so if this requires popping this sucker open and doing something, I'm game.

    Thanks for any replies in advance.

  2. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    May 14, 2006
    Roskilde, DK
    Try disconnecting the CD drive and turn it on?

Share This Page