ibook connecting to Epson printer on Windows XP PC

Discussion in 'Macintosh Computers' started by amsquared, Jan 5, 2004.

  1. amsquared macrumors newbie

    Joined:
    Jan 5, 2004
    Location:
    Scotland
    #1
    My daughter has a new ibook G4.

    I have added it to our Home Network and it connected to the internet as soon as I plugged the ethernet cable in. The Network consists of a Linksys BEFSX41 Router, 2 Windows XP PCs and the ibook. The router connects to the internet via a cable modem.

    I have an Epson 890 connected via USB to one of the Windows PCs. The PCs both run ZoneAlarm Pro the IP address of the ibook is in the trusted Zone.

    When I select Network in Finder I can see the Home network

    I am struggling to work out which option to choose in the Set up printers dialogue on the ibook.

    If I choose Windows Printing and Network Neighborhood I can see my Network but when I select that Network I can't then do anything else.

    Sorry I've never setup any Apple kit before so any advice please make it pretty simple.
     
  2. 7on macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #2
    Is printer sharing turned on on the PC?

    Somewhere else I read that Unix Printing must be enabled for the PC as well.
     
  3. zyuzin4 macrumors 6502

    Joined:
    Jul 22, 2002
    Location:
    Eugene, OR
    #3
    I had this same problem. The mac and the pc with the printer have to belong to the same workgroup.

    Go to Applications/Utilities and run Directory Access. Select SMB, then click Configure. Now, enter the pc workgroup name and that should allow you to see the printer
     
  4. amsquared thread starter macrumors newbie

    Joined:
    Jan 5, 2004
    Location:
    Scotland
    #4
    Ok that worked I manged to select the printer connected to the XP PC and install it with the correct driver and make it the default printer. On trying to print I get the following error:

    NT_STATUS_ACCESS_DENIED after a while this message changes to Unable to connect to Samba Host will retry in 60 seconds and repeats the same Error message.
     
  5. zyuzin4 macrumors 6502

    Joined:
    Jul 22, 2002
    Location:
    Eugene, OR
    #5
    When you added the printer, it should have given a prompt for a user name and password. If you remember that, did you just push enter ? I think it requires a user name to communicate with the other computer or printer.

    Try deleting the printer and adding it again, see if it asks for the user name and pass again. This time add anything to the user name. This is all assuming that your PC permissions are set to everyone having access.

    It is possible that deleting and adding the printer again won't give the user/pass prompt because the blank entry was saved to the keychain. If you find this to be the case, look in Keychain Access in Utilities i believe. Under SMB there will be a stored password for the Print Setup Utility. Delete the key and when you add the printer, it will ask you again

    Hope This Helps!
     
  6. amsquared thread starter macrumors newbie

    Joined:
    Jan 5, 2004
    Location:
    Scotland
    #6
    Thanks that worked first time - there wasn't anything in key chain access. I just deleted the printers and added a name when requested in the user dialogue.

    Now just need to play around with file sharing and everything will be OK for my daughter's homework.

    Thanks again.


    Amsquared
     
  7. zyuzin4 macrumors 6502

    Joined:
    Jul 22, 2002
    Location:
    Eugene, OR

Share This Page