iBook: Each keypress produces high pitch squeak.

Discussion in 'Macintosh Computers' started by ITASOR, Nov 1, 2005.

  1. macrumors 601

    ITASOR

    Joined:
    Mar 20, 2005
    Location:
    Oneida, NY
    #1
    This is really weird, but has been like this since I got my iBook on August 12th.

    If I open TextEdit, and press any key, it produces a "squeak" noise. It sounds like its coming from the speakers, but I'm not 100% sure. If I hold that key down, the very low squeak sound happens over and over until I let go. It's VERY faint of a sound and I can only hear it when everyone's really quiet and I try and type more softly than usual.

    This doesn't happen ANYWHERE else, besides TextEdit.

    Any idea? All my keys do this, not one in particular. Again, ONLY in Text Edit.

    How weird is that?
     
  2. macrumors newbie

    Joined:
    Aug 2, 2005
    Location:
    Scotland
    #2
    Weird indeed. I have noticed this but only ever when writing, guess where........... on macrumours!!!! Even more weird, for the first time ever, it is not doing it just now! On a previous post somebody referred to this as a hard drive noise but I am not totally convinced by that. Am just putting it down to "character".... Now you wouldn't hear that from a pc owner!
     
  3. macrumors 68020

    Joined:
    Mar 30, 2004
    #3
    Weird! My PowerBook does the same thing!
     
  4. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  5. macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    My PowerMac G4 Quicksilver 2002 does the same thing at work. I'll try it while muted.
     
  6. thread starter macrumors 601

    ITASOR

    Joined:
    Mar 20, 2005
    Location:
    Oneida, NY
    #6
    Muting or increasing/decreasing the volume doesn't do anything.

    I'm glad I'm not the only one. After a while, the noise stops in textedit, but then it's back next time (like few days later). I thought maybe it's the HD noise with "autosave" or something, but it doesn't do that anywhere else for me.

    I called Apple, they had NO CLUE what I was talking about.
     
  7. macrumors 65816

    maverick808

    Joined:
    Jun 30, 2004
    Location:
    Scotland
    #7
    I *may* have a solution. Install the dev tools (xcode) if you haven't already (it's on the OS X cd). Once you install that you will end up with a Processor preference pane in System Prefs. Go into that and uncheck the box that says "Allow Nap".

    Please let me know if it works. Thanks.
     

Share This Page