iBook G4 and Flash

Discussion in 'PowerPC Macs' started by sananda, Oct 26, 2010.

  1. macrumors 68020

    Joined:
    May 24, 2007
    #1
    My iBook G4 1.33GHz (Leopard) has Flash Player 10.0.22. I guess it has updated to this version via the point updates of Leopard or via Security Updates.

    Now that there aren't any more point updates for Leopard (and maybe Apple won't be sending out Flash updates anymore), should I be updating Flash myself?

    If so, will the current version work better on my G4?
     
  2. macrumors member

    india349

    Joined:
    Oct 19, 2006
    Location:
    Minneapolis, MN, USA
    #2
    "Better" seems to be quite relative, as it depends on what kind of Flash (games, video, etc) you're using, how much RAM your browser is using, and even what site you're on.

    I have a 12" PowerBook G4 1.5 Ghz and I would say that Flash video is playable on most sites (CNN, New York Times, CNET video all seem to load and play find on Standard Definition). YouTube, depending on the version of the player is hit or miss. Anything VEVO is out. Anything on Hulu is out. For the record, I'm using the latest version of 10.1.

    I've tried downgrading to Flash 9, but there wasn't a big enough difference (it was still slow on certain sites), so I figured I would keep updated with the latest security and just deal with it.

    To answer your question, I don't remember Apple ever pushing Flash updates through Software Update, but yes, you'll have to update manually now. We should be thankful, really, that Adobe is still bothering to even support the G4, despite its performance.
     
  3. thread starter macrumors 68020

    Joined:
    May 24, 2007
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-gb) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    Looks like 10.1 is working out ok for you. I suppose I should update if only security reasons. Thanks for the info.
     
  4. macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #4
    I have the same model as the OP. I'd definitely keep Flash up to date for security purposes and would try to use HTML5 where possible.
     
  5. thread starter macrumors 68020

    Joined:
    May 24, 2007
    #5
    I'll do that. Thanks.
     

Share This Page