1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iBook G4 freezes (?!) when closing lid (setting it to sleep)

Discussion in 'Macintosh Computers' started by tkermit, Apr 17, 2004.

  1. macrumors 68030

    tkermit

    #1
    hi everyone,

    once again I'm having problems with my iBook.
    Every now and then (well, I can't remember a ">1 day" uptime, so it kinda happens every day), my iBook, when I try setting it to sleep by closing the lid, decides to act in a very strange way.
    It turns off the screen, but apparently doesn't turn off anything else. I can still hear the fans and it seems to access the harddrive every ~10-20 seconds. When I finally realize that it's not going to fall asleep, I open the lid again, which doesn't change anything. The screen is still black (turned off), and the computer doesn't react to any input (only solution: control/command/power or pressing the power button for >5 seconds).

    Is it at all possible that the reason for this behaviour is a hardware fault ? (I just had my iBook repaired ~1month ago ) Or should I assume it's some kind of software conflict?

    What I have done so far:

    - restart (obviously)
    - repaired permissions
    - ran maintenance scripts (daily,weekly,monthly)
    - ran optimization script
    - deleted/cleaned user/system cache and swapfile
    - reset NPRAM

    What else can I do ? (well I know I could try to reinstall Mac Os X, but I'd really prefer only doing that if I know that it'll help / if it is the only solution.

    So, once again I'd appreciate ANY help. Thank you so much,

    christian
     
  2. macrumors 65816

    abhishekit

    #2
    try resetting the PMU..if its a g4 ibook, shut down.... press Shift-Control-Option-power..hold down for 10 sec..release....wait for 10 sec..power it on..
    hope it helps
     
  3. macrumors 601

    zimv20

    #3
    kermit - i assume that the sleep light never comes on? (and pulses, obviously)
     
  4. macrumors 68030

    tkermit

    #4
    thanks, but I already did that. (that's what I meant when I said that I reset the NPRAM )


    right, it actually feels like the laptop is stuck somewhere in the "going to sleep" process...
     
  5. macrumors 601

    zimv20

    #5
    my g3/ibook does something similar, though it eventually does sleep (light pulsing).

    it had misbehaved for a while (the screen would stay on when i closed the lid); i tried all manner of fixes (including all those you mentioned), but then it kind of "fixed itself," or i accidentally fixed it when investigating.

    what i did was take a magnet to the reed switch -- that's the thing that senses a closed lid. on my ibook (and i assume yours) it's inside the lid, a couple inches below the mic. put a magnet up against it and the machine should sleep. pull the magnet away, it should wake up.

    give it a try.
     
  6. macrumors 68030

    tkermit

    #6
    ok, I just did it a couple of times (Actually, right next to me I had one of those magnets you use on bicycles to measure your speed). Worked beautifully, like it should. I don't think this solved anything, though. As I said, most of the time, closing the lid also works. Even when it doesn't, the reed switch must still recognize the magnet under the right palmrest, right ? (because it starts going to sleep (the display turns black and all that)) .
    Since you said that your book eventually went to sleep, I just want to add, that I actually waited a few times for it to fall asleep (5min. once) (to see if it just takes some time, but it doesn't do anything (keeps running)).
    Thanks for your answer , I'll see if it changed anything... :eek:
     
  7. macrumors 601

    zimv20

    #7
    fwiw, mine doesn't take anywhere near 5 minutes, maybe 5 seconds.

    i'm not sure if my magnet experiment really did anything to fix it, but the timing was coincidental. about the same time, i stopped folding on the ibook -- maybe the problem was heat related?
     
  8. macrumors 68030

    tkermit

    #8
    ...it happened again... :(
    I'm not sure though if it's maybe related to the battery status display on the top of the screen. I kinda got the impression that it only behaved like this when it was set to display the remaining time (but even then there is no real pattern...) . Any other ideas ? :confused:
    Thx, chr. :)
     
  9. macrumors 68030

    tkermit

    #9
    update: I just went ahead and reinstalled OS X (ran diagnostic software beforehand / reset PRAM again / reset open firmware ram / initialized HD etc. ) and the problem is STILL there -
    I'm beginning to think it must have something to do with the hardware, basically I'm ready to call Apple...
     
  10. macrumors 6502a

    titaniumducky

    #10
    Definitely call Apple! I'm assuming it's still under warranty. This a serious hardware issue with the PMU (esp. since resetting it didn't help). You probably have a lemon.
     
  11. macrumors 68030

    tkermit

    #11
    ok then, I guess that's the way to go. Isn't it weird though, that it doesn't happen all the time, but only on occasion ? :confused:
     
  12. macrumors newbie

    #12
    tkermit-

    mine did the SAME thing as yours... i had to end up sending it in after hours on the phone with tech support.... they ended up replacing the logic board, however, i had it for ONE day and had to send it in AGAIN!! this time it's the hard drive. figures.
     

Share This Page