ibook G4 shuts down instead of sleep

Discussion in 'PowerPC Macs' started by Cox Orange, Sep 11, 2011.

  1. Cox Orange, Sep 11, 2011
    Last edited: Jan 6, 2014

    macrumors 65816

    #1
    Hello,

    my ibook G4 12", 1,33GHz, mid2005 immediately shuts down, if I click on "go to sleep" in the menu. It is like having no battery in and pulling the powerchord out of the wall. No process of saving files or anything, before it shuts down. (EDIT: I can see the sleep light lighting up for a tenth of a second)

    If I change the energy setting to 1min and I wait, in order to have it go to sleep on its own. It goes black, no sleep light (even not for a milisecond), but I can hear the HD still moving. When I hit the track-pad, it wakes up (remember I did set the computer to 1min sleep and not only the monitor). BUT! As far as I remember, you always had to push a key or the trackpad-button to wake it up. Wiping with your finger only made the screen awake from sleep, I thought.

    PMU reset does has no effect. The ibook stays dead.

    One of the two things help always, to bring it to life again:
    1. unplug the power chord, pull out RAM wait, insert RAM, plug in powerchord and start (if option 2 does not work)
    2. plug out power chord, pull out battery, wait. put battery in, conect power chord, start.

    My old ibook got broken through an accident. I purchased a "new" working one and put my old case(including display case) around it and I changed the HD to a WD3200BEVE.

    I first thought it is the new HD, because external WD drives sometime have problems with waking up. But I started the ibook from an external old Seagate via firewire and then clicked on "sleep" and it shut down the same way. Could that be a hint, that it is the logicboard and not the HD?
     
  2. macrumors 65816

    #2
    installed the OS completely new and it still had the issue of not going to dead instead of sleep. I guess I can narrow it down to hardware.

    When I start it via firewire and let it go to sleep it has the issue, too. Now, is this the hint, that it IS the mainboard not the HDD?
     
  3. macrumors 6502a

    #3
    Couple of things spring to mind:

    How old is the battery (i.e. how many cycles)? I' understand that this can occur when the battery is old and can't hold a low charge.

    The iBook has a PRAM backup capacitor instead of a PRAM battery; when this capacitor deteriorates over the years then the iBook can't sustain a battery change without losing time & date etc. and I've heard that this can also affect sleep.

    That said - I recently aquired a G4 PowerBook with the exactly same problem. It had a third party battery that also wouldn't calibrate. I replaced the battery with an Apple original and the problem went away.
     
  4. macrumors 65816

    #4
    Thanks for your tips!

    I tried it with two batteries. One had 79 load cycles (actual capacity according to coconut battery 2.6.6 is 18%), the other had 333 load cycles (69% actual capacity).

    It happens with both batteries. Whether the time and date is remembered is up to how long I wait till I plug in the cable and battery again after shut down. So it could be the capacitor, ha?

    I plan to open it again anyway (to change the harddrive, which I am not happy with because it is louder than the stock one, though it is cooler and more powerful, a 320GB WD), I might get me a new mainboard on Ebay and change this, too.

    Btw, I sold the parts of my old dead ibook seperately on Ebay and got the same overal amount of money as a working ibook of the same type costs. Crazy, somehow...
     
  5. macrumors 6502a

    #5
    IIRC the capacitor is only designed to last about a minute or less before losing the time.date/etc. settings - i.e. just enough to let you swap batteries.
     
  6. macrumors 65816

    #6
  7. macrumors 65816

    #7
    I did not do the capacitor swap by now, but I discovered something new.

    I knew that a PMU reset did not help, but I did try it again and again, no success, the Mac keeps going dead instead of going to sleep.

    BUT! I accidentally got into saved-mode, by first pressing the power-button and then holding the PMU-reset-keys (shift + ctrl + option-key).

    In save-mode I can get the ibook into sleep and awake it again.

    Does that tell anything?
     
  8. macrumors regular

    ifrit05

    #8
    What is "Saved-mode"? Never heard about that before.
     
  9. macrumors 65816

    #9
    Wrong word, sorry.

    It is safe-boot. http://support.apple.com/kb/HT1564?viewlocale=en_US
    (kexts are not loaded, so that they can't get in the way).

    User Intell got me some information and it comes down to the following.

    "You're starting it up in Safe Boot by holding shift at startup? That could indicate that you may have a problem with either your user account, a third party application or extension, or a hardware problem that only presents itself when the kext for that hardware is loaded."

    1. Back then I reinstalled the OS from the install discs = so User account is out of the discussion, I think
    2. with the new OS-install I did not have a third party application or extension installed, so that is out of the discussion, too.
    3. hardware: that must be it. Now I would have to figure out what kext is prohibiting my Mac from sleep and then I could find what hardware component it is.
     
  10. macrumors P6

    Intell

    #10
    Check the Console logs to see what may be causing problems when sleeping or resuming from sleep.
     
  11. macrumors 65816

    #11
    There seems more than one thing "did not complete successfully".

    I deleted my Username and put USERNAME in here.
     
  12. macrumors P6

    Intell

    #12
    It seems from the log that it went to sleep or was turned off at Jan 8 23:52:32 and it started at Jan 8 23:53:15. Could you possible post more of the log before Jan 8 23:52:32?
     
  13. Cox Orange, Jan 8, 2014
    Last edited: Jan 8, 2014

    macrumors 65816

    #13
    No, the time I put it into sleep is not written down in the log, it was at 23:55. I just started it aaround 23:52 and then let it sit till 23:55 and then hit "sleep" from the menu. Then the ibook went dead immediately (after a only once flashing sleep light). I then plugged off power cable and battery and restarted it at 23:57 again.

    I did do it again, because I wasn't sure anymore, if I perhaps got the wrong piece out of the log.

    NEW TEST:
     
  14. macrumors 65816

    #14
    log data before 23:52, as you required
    the last is the same as the first line in my older post.
     
  15. Cox Orange, Jan 8, 2014
    Last edited: Jan 9, 2014

    macrumors 65816

    #15
    What strikes me is the entry "ApplePMU::pMU forced shutdown, cause = -127", but that the log keeps collecting data after that event. I also know the ibook was still running after that "shutdown" entry. Hm...

    Google comes up with a different cause number (it is -122 indicating something with the external power is wrong).
     
  16. macrumors P6

    Intell

    #16
    I think the problem is with the /Library/StartupItems/PACESupport item. The PMU shutdown log event happens when the Mac is starting up again. The kernel asks what was the last shutdown or power off cause and the PMU response with the reason. It varies by model, but the -12X reasons are usually normal. It's the positive and -10X reasons that are mostly bad.
     
  17. macrumors 65816

    #17
    Thank you very much!

    Is /Library/StartupItems/PACESupport an item, that gets installed newly, when the OS will be installed? I already had tried installing the OS new and that did not make a difference to the sleep issue.
     
  18. macrumors P6

    Intell

    #18
    No, it's a third party thing that has something to do with anti-priacy. Make sure when removing it remove the extensions for it as well. Use a search engine to find out exactly what needs removed. When you reinstalled the OS, was it an archive and install or a wipe and install?
     
  19. macrumors 65816

    #19
    wipe and install.
     

Share This Page