1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iBook G4 USB ports...identical?

Discussion in 'Macintosh Computers' started by mkrishnan, May 13, 2004.

  1. Moderator emeritus


    When I first got my iBook (12" G4 800 MHz), a friend brought over his Digital Elph, and we tried to plug it into my iBook to see how iPhoto imports work. We found that one of the ports (the one nearer the FW port) didn't do anything when we inserted his camera, but it was automatically recognized on the other one (the one next to the display port) and worked fine.

    Since I don't use USB much and I have a warranty, I kinda ignored it. But now I got my own camera (Powershot S50), and same deal.

    Just to make sure I'm not crazy or ignorant, there isn't any difference between the two USB ports on the iBook is there, like one being powered and the other not? This should not be happening, right? :(
  2. macrumors 68040


    No that should not be happening. I'd contact Apple ASAP. Both USB ports on my TiBook (1Ghz) and my wife's iBook (800Mhz G4) work with our digicam.
  3. macrumors 68020

    yep, its a flaw. get that fixed right away! hurry! go now!
  4. Moderator emeritus


    I'm running, I'm running! :) Thanks for your help, Michael and Mactastic!
  5. macrumors 68040


    is it just the camera? does the problem happen with other USB devices, like a mouse?

    i agree that you should have it checked out. (and since you are in troy, there's an apple store right there!)

    i was just curious...
  6. macrumors 65816


    I have the same problem with my iBook G3 500!

    If I plug my digital Elph into the front USB port, the iBook will not recognize it. But, if I plug it into the back USB port, it works.

    BUT, every other perepherial works on both ports! I can use my printer on both, a USB hub on both, my Palm HotSync crable on both, just not my digital Elph. So, I think it's an issue with the camera or USB cable and not my iBook.
  7. Moderator emeritus


    Hmmm...all Canon cameras...hmmm...very curious. Thanks -- I'm gonna look and see if I have any other Mac compatible USB devices. My mice are either PS2 or BT. :( I have a scanner and a USBCam but I'm pretty sure they're not macable. Well, maybe if I find drivers? Maybe I can ask at the Apple store too. I have to go back there today bc I bought something there a couple days ago and they gave me somebody else's receipt. :)

    EDIT: ooh, ooh, my printer (duh)...BC its been on my AEBS the whole time I owned it, I forgot all about it. :)
  8. Moderator emeritus


    Yeah...my printer at least DOES get *recognized* on both ports, which is more than I can say for my camera. VERY strange. I guess I will take my iBook with me to the Apple store this afternoon.
  9. Moderator


    Staff Member

    Both USB ports works fine on my iBook G4 when connecting my HP Photosmart 435...
  10. Moderator emeritus


    Hmmm...I opened my iBook to make sure I knew which USB port was which (working & not working) just before going to the Apple store, and whaddya know...they both work. Tried putting it back to sleep and waking it and still works. Tried repeatedly swapping it (plugging it in, waiting for iPhoto to recognize it, unplugging it, waiting for iPhoto to drop it, repeat ad nauseum) and still no issue.

    Tried it again now and it still works. Almost like plugging the printer in woke something up. :confused:

    Major weirdness.

    Now I just gotta keep an eye on it during my warranty period to make sure it doesn't recur....
  11. 7on
    macrumors 601


    Yeah, my tibook was having a problem with the right USB (when looking at it from the rear) but a restart fixed it. Twas weird.
  12. macrumors G3

    Chip NoVaMac

    I have the same issue with my PB 12" and how the USB is recognized....
  13. Moderator emeritus


    Same meaning it doesn't work; it didn't work, but does now; or it does work? It's a moving target! :D
  14. macrumors G3

    Chip NoVaMac

    Should explain further.

    The USB port closest to the FW400 port is the only port that I can get my USB hub to recognize and print from. The other one is fine for the keyboard and mouse.
  15. Moderator emeritus


    It almost sounds like a power (electrical) issue, doesn't it? Like the only devices we have trouble with are USB-powered devices that take a relatively larger amount of juice. Of course I can't explain why mine works now. :(

Share This Page