1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iBook Won't Startup?!?!

Discussion in 'PowerPC Macs' started by chopsuey158, Jul 24, 2005.

  1. macrumors member

    #1
    I was trying to install os 9 on my ibook G3. It had os x installed but I have several games that will only run in os 9. I tried multiple install discs but kept recieving a bus error. Then, I networked two computers and just copied os 9 from one to the other. I then tried booting off of this and it gave me the same bus error. Now, I can't get the computer to turn on with anything except the os 9 which gives me the bus error. I have tried to change the startup disc using the cd and holding down option at startup but the computer doesn't recognize any operating system other than the os 9 (which won't work). Does anyone know how I can 1) get back to os x without wiping the hard drive, and 2) install a working copy of os 9? Possibly someone with some knowledge of the firmware would be of help...

    Thanks!

    iBook G3 dual usb 500 mhz 80 gig hard drive 576 meg ram
    4g 20 gig ipod :(
     
  2. macrumors 68030

    Duff-Man

    #2
    Duff-Man says....try holding the 'X' key at startup.....oh yeah!
     
  3. macrumors member

    #3
    I tried that also, it doesn't recognize the os x system folder...
     
  4. macrumors 68030

    Duff-Man

    #4
    Duff-Man says...next easy step to try - zap the pram...hold command+option+p+r and let it "bong" a couple times....oh yeah!
     
  5. macrumors member

    #5
    Sorry about not being more specific to begin with (I'm a macrumors newbie). The things I've tried are:
    Hold down X at startup ("?" flashed with a face until I let up)
    Hold down Option at startup (only os 9 was recognized)
    Hold down Option Command Shift Delete at startup
    Boot off of CD to change startup disk (cd didn't recognize os x)
    Booted into the firmware (but didn't know what commands to use)***
    Cleared pram, nvram and pmu (with key commands and using the firmware)

    ***Does anyone know what commands I should use in the firmware? I think this may be the only way to fix the problem but I am not familiar with the commands...
    Or, would a network boot do anything?

    Thanks!
     
  6. macrumors member

    #6
    Fixed it!

    Here is what I did to fix it in case anyone else has this problem. I booted off of an OS X cd and reinstalled OSX saving the preferences and files and what not. Then, I rebooted off of the OS 9 cd, and it recognized the OS 9 system I had copied from my second computer over so it allowed me to install a new version of OS 9 over this older version which wouldn't work correctly. Then, I simply change the startup disc to whichever one I wish to use at the time, or hold x down to have it boot into OS X without having to change the startup disc. Thanks for the help anyway Duff Man.
     

Share This Page