iChat AV problem

Discussion in 'Mac Apps and Mac App Store' started by Chuck, Jul 11, 2003.

  1. Chuck macrumors regular

    Joined:
    Jan 3, 2003
    #1
    I've been trying to get iChat AV to work with my sister who lives across the other side of Australia. We've both looked at what you need to get it going and we've both got everything: iSight cameras, G4 machines, up-to-date OS versions, broadband DSL internet connections...

    It allows us to invite each other to do a video chat, but when it tries to connect us, the window freezes and then goes green and it says "Not enough bandwidth to obtain a connection" which is not true since we're both on broadband connections.

    We've tried altering the bandwidth limit in preferences and that didn't change a thing.

    Is there some way that perhaps one or both of our machines (mine's a PB 17") is not detecting that our connection is in fact as fast as it is? Have we got it set to think we're on a dialup or something?

    I don't know and Applecare aren't much help (it usually takes calling them 3 or 4 times to find someone who knows what a solution to my problems anyway).

    Any thoughts? Anyone had a similar problem?

    Thanks in advance. I'd love to do a video chat with my sister so I can see my two nieces.

    Chuck.
     
  2. Flowbee macrumors 68030

    Flowbee

    Joined:
    Dec 27, 2002
    Location:
    Alameda, CA
    #2
    You can check the speed of your broadband connections at a site like this one: http://webservices.cnet.com/Bandwidth/

    Just because you have a broadband connection, doesn't mean that you're necessarily getting the bandwidth to run iChatAV. Until recently, I was paying for a DSL connection that was averaging 175kbps (ugh). There were lots of 'broadband' features I couldn't use.

    Anyway... just a thought. Might be the first thing you want to check.
     
  3. Chuck thread starter macrumors regular

    Joined:
    Jan 3, 2003
    #3
    Hey you might be right! I just checked with my provider and they said I was on a plan which had a maximum of 256kbps download and 64kbps upload.

    I have now changed it to a plan which has a maximum of 512kbps download and 128kbps upload. Only problem is that this won't take effect until the first of August so I won't know if it fixes it until then.

    The plan above this one is just too expensive. It's got a download of 1500kbps and upload of 256kbps but it's a hundred bucks more than the one I'm upgrading to, per month.

    Hope this works! Thanks for the tip.

    Chuck.
     
  4. seesaw macrumors newbie

    Joined:
    Jun 24, 2003
    Location:
    Oz
    #4
    Have you checked iChat's Preferences
    - under the Video Preference -
    apart from the Video Window and the Microphone:<selector>

    There should be Bandwidth Limit:
    Play with differing values to get a good connection

    If it doesn't appear
    there is a command line solution for editing the preferences in com.apple.iChat

    open Terminal.app and type:
    defaults write com.apple.iChat VCMaxBitrate 200

    Replace 200 with a higher/lower value, may work

    I can communicate with audio very well with a friend on a B&W who has 56k modem

    hth
     
  5. irmongoose macrumors 68030

    irmongoose

    Joined:
    Dec 3, 2001
    Location:
    Sometimes Tokyo, sometimes California
    #5
    iChat AV is still beta. Many people who have the needed setup (including me) have absolutely no luck using it no matter what we do or who we try to AV chat with. I hope Apple's next release of iChat gives better results.

    As I see it, many people in the US (and maybe Europe) seem to be able to use it, but nobody I know in any other country has been able to use it. Either it's a funny glitch or Apple has yet to implement the needed network settings for other countries in this first public preview version.



    irmongoose
     
  6. Dreamail macrumors 6502

    Joined:
    Jun 17, 2003
    Location:
    Beyond
    #6
    Chuck, I'm pretty sure that's what it is. Your bandwidth is not high enough.

    iChat AV explicitly requires a DSL/Cable connection to do video chats. Simply because a modem connection at 56Kbps isn't enough bandwidth. While your specific DSL connection downloads at 256Kbps it only uploads (i.e. would send video signals) at 64Kbps. If 56Kbps is not enough for video, I strongly doubt that 64Kbps would be any much better. You'd probably need at least 128Kbps if not 256Kbps upload speed for iChat AV to do video. Too bad iChat AV is not more specific about bandwidth requirements for video (http://docs.info.apple.com/article.html?artnum=93245) it simply lists 'Cable, DSL, or other broadband Internet connection'. What I suspect is that nowhere in the US one can get such a low bandwidth DSL connection as yours with just 256/64, which is why Apple didn't bother to be more specific about which speed of DSL is required for video chats.

    I have a 512/256 DSL connection (download/upload) and am able to do video chats. So 256Kbps upload is enough. Whether 128Kbps would also work I don't know.

    One thing I also noticed is that the encoding process takes up a lot of CPU calculation power. In order to do video chats on a G3 Mac you need at least a 600MHz G3.
    But the G4 doesn't fare much better. A friend of mine I do video chats with has a 500MHz G4 PowerBook and that is pretty much busy 100% when we do video chats. The moment he's starting to do something else while we're chatting, even just browsing the Finder, I get dropped frames a lot. And if he's doing some Photoshop filters or such the video halts altogether for a while.
     
  7. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #7
    I've got a 128/128 but I don't have a camera so can't comment or how well it'll work (or whether it'll work at all). I remember when AV was first announced, I asked on here whether anyone knew what "broadband" actually means, I don't think anyone had an answer.

    Edit: They've updated the site, it now says that you need 100 or faster (presumably in both directions).
     

Share This Page