ichat problem

Discussion in 'Mac Basics and Help' started by uneducated dave, Jan 9, 2007.

  1. uneducated dave macrumors member

    Joined:
    Sep 19, 2006
    #1
    ok, so i have a C2D 17inch 2ghz iMac. my girlfriend has the lower end 17inch model, the C2D 1.83ghz one. we've been using the video chat function on ichat since being at university to keep in touch, and it has been most helpful!

    however recently, since the christmas period...it hasn't worked. every time one of us requests a video conversation we get "error-8" and it says one of us failed to respond...something like that.

    i thought it might be a problem my end - but i tried a video conversation with my dad (who has an imac G5) earlier and it worked just fine. i only seem to get the error when talking to her.

    anyone have any ideas as to whats going on, and how we could possibly resolve it? we both have installed the recent update that was released.
     
  2. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #2
    Has anything changed (other than the iChat update)? Any moves? New routers? Changed settings?

    It's likely that a port isn't being properly forwarded on one end or the other.
     
  3. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #3
    The only thing that comes to mind is that one of your connections might be slower (this can happen if you, for example you are on cable modem and your neighbors all get computers)...

    My advice is to open up the preferences in the ichat menu, the select the video icon...and you'll have a bandwidth limit option...try lowering that and see if that helps at all.

    You guys can still audio chat or does it give you a similar error with that?
     
  4. uneducated dave thread starter macrumors member

    Joined:
    Sep 19, 2006
    #4
    thanks for the reply!

    we tried lowering it but it still didn't work.

    we tried an audio chat we're getting the same error, error -8. any idea?
     
  5. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #5
    It's probably a hardware (modem, router) or network settings problem then...you said the chat with your dad worked...are you guys on the same router using the same modem to connect to the internet?

    If so, can you video or audio chat to other people outside your local network? Can your girlfriend video or audio chat with people outside hers? That would be the next step to try and pinpoint the problem.
     
  6. uneducated dave thread starter macrumors member

    Joined:
    Sep 19, 2006
    #6
    nah when i chatted with my dad he was at work and i was at home. the video chat with my girlfriend didn't work when she was at her own home; now she's back at uni though - but it still doesn't work. i think it must be a problem with the settings or ichat itself on my girlfriends computer! thank you for your help so far, it is appreciated. i'm stumped!
     
  7. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #7
    I think you're right...the fact that her chat still doesn't work at home or uni suggests that it's on her side. You might still have her try to video or audio chat your Dad (or anyone else outside the uni's network) up to see if that works, just in case.

    I just found this thread, check out the apple document linked. Looks complicated.

    Good luck.
     
  8. uneducated dave thread starter macrumors member

    Joined:
    Sep 19, 2006
    #8
    ah that looks like what we're looking for! i'll just ask her to turn her firewall off whilst she chats to me, i've just discovered mines been off for quite a while!

    thanks for all your help mate.
     
  9. uneducated dave thread starter macrumors member

    Joined:
    Sep 19, 2006
    #9
    so it turns out her firewall already was off - it still doesn't work! i don't know what to do.
     
  10. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #10
    Personally I would make sure both your firewalls are on for security.

    Also have you tried ticking the Personal File Sharing option in the firewall menu?

    I had a problem with iChat once. Turned Personal File Sharing on and never had a problem since. :confused:
     
  11. uneducated dave thread starter macrumors member

    Joined:
    Sep 19, 2006
    #11
    we tried turning personal file sharing on but it didn't work. thanks for the reply though!
     
  12. bitabytex macrumors member

    Joined:
    Oct 26, 2006
    #12
    here is a snippet (a big snippet) from mvldesign.com about the issue and how to fix it. Hopefully this helps:

    Mac OS X 10.4 internal firewall: For Mac OS X 10.4 Tiger you can specify TCP and UPD ports separately. The Firewall is in the same place but after selecting the New button select Other from the pull-down menu. TCP ports: 5190, UDP ports 5060, 5190, 5678, 16384-16403. Give the entry a name like iChat and click OK.

    Please note: I do not have my internal OS X firewall turned on.

    Routers:
    Click on image to see a typical router set-up for conferencing
    External firewall / router settings: Click on the image on the right to see a typical Linksys router setting for opening the ports that iChat and AIM uses. For a more complete description see the page on Apple's web site Using iChat AV with a firewall or NAT router or the page that shows each port and what it does. If you want the short version: open ports 5060, 5353, 5678, 16384-16403 for UDP and 5190, 5297, 5298 for both UPD and TCP. D-Link router set up.

    Once you have manually opened the correct ports (if you actually need to) video conferencing is quick and easy. Please note: I used to have my system behind the above pictured Linksys router and did not have any ports "opened" (even though the photo indicates I did) and had no problems connecting to PCs with AIM or Macs with iChat AV.

    The AIM web site states that if either you, or the person you want to video conference with are behind a firewall and are having problems getting it to operate, "work with your Internet Service Provider, your company's system administrator or modify your firewall software yourself to open ports 1024 through 5000." Though opening all those ports seems excessive it is what AIM suggests so is mentioned here for completeness. Also, I don't understand why they say to open only those ports as the 16384 and 16385 are the two most likely to be used for audio and video.

    If opening local router ports does not help move the equipment to another location to see if you can then connect. If so, then there is a firewall or other hardware device blocking access at the original location. Some universities regularly block access to video conference ports.
     
  13. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #13

Share This Page