iCloud as default email? Why?

Discussion in 'iPhone' started by spartanrob, Oct 20, 2011.

  1. macrumors 6502

    spartanrob

    Joined:
    Aug 4, 2008
    #1
    I have my gmail account set as default, but often times when I access Mail, it defaults to iCloud. I have 2 gmail and one exchange account. Why does it keep defaulting to iCloud
     
  2. macrumors member

    Joined:
    Jun 9, 2011
    Location:
    Atlanta, GA
    #2
    Settings -> Mail, Contacts, Calendars -> Default Account
     
  3. thread starter macrumors 6502

    spartanrob

    Joined:
    Aug 4, 2008
    #3
    Yep, already done "I have my gmail account set as default"
     
  4. macrumors regular

    TheNinjaJedi

    Joined:
    Jul 16, 2011
    #4
    so you're saynig it switches it back to iCloud?
     
  5. macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #5
    It's not really defaulting to it, but if you're sending from mail, it will send from whatever box you're currently in, unless you change it.
     
  6. macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #6
    IE: If I open mail to send something and the last box I was in was my iCloud, that's what it will send from, unless I change it.

    It only reads the one you have set as a default, when you are sending from some other application, like photos, or Safari.
     
  7. thread starter macrumors 6502

    spartanrob

    Joined:
    Aug 4, 2008
    #7
    gmail is always set as default.
    I never use iCloud email.

    Many times when I access email, it goes directly to iCloud. Makes no sense.
     
  8. thread starter macrumors 6502

    spartanrob

    Joined:
    Aug 4, 2008
    #8
    Just power-cycled the phone.
    Clicked on eMail and it went right to iCloud :mad:
     
  9. thread starter macrumors 6502

    spartanrob

    Joined:
    Aug 4, 2008
    #9
    Still having this issue. Anyone else?
     
  10. macrumors 6502

    Joined:
    Nov 13, 2008
    #10
    yes.

    if i compose an email from the top level of the email app (ie looking at all my mail boxes) it will default as being sent from my @me address. if i force quit or power off and on my phone and access mail it will go straight in to my icloud inbox, so i have to go back and then in to my gmail. i have 3 email accounts on my phone; icloud, gmail and a work exchange account. gmail is set as my default. i sometimes forget about this so occasionally send emails out from my @me address when i don't want to. it's a little bit of an annoyance because i never used to have a me account so never had this problem, it always used my gmail account as you'd expect since it is my default.

    i'll probably try restoring again at some point.
     
  11. macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #11
    turn off icloud email
    goto icloud.com and set to forward to gmail and delete

    have one email account in phone, nice and simple...
     
  12. macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    Guelph ON, Canada
    #12
    I have 5 email accounts on my phone and gmail is default and it always uses gmail unless I am in a specific mailbox and compose an email there or replying to an email from whatever account.
     
  13. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #13
    I've found that when you open the Mail.app after either restarting the phone or fully closing out the app (via the multitasking toolbar), the app will open right to the inbox of the top-most email account in Settings>Mail, Contacts, Calendars. I have my Gmail (set up as Exchange) as my default as well but my iCloud account is at the top of the accounts list in Settings>Mail, Contacts, Calendars so the Mail.app often opens up to the iCloud inbox regardless.
     
  14. macrumors 604

    ZBoater

    Joined:
    Jul 2, 2007
    Location:
    Sunny Florida
    #14
    This is Apple's not so subtle way of telling you to ditch Gmail and go iCloud.... :p

    This happens to me too. Must be a bug. Or a feature.
     
  15. macrumors 68020

    Joined:
    Aug 13, 2008
    Location:
    Kitchener, Ontario
    #15
    I just tried changing my Default Email and it actually changed it...I'm actually using my iCloud email more now compared to my Gmail, but I can change my default in the settings...

    Try changing it to something else and then going back?

    Also, when I force quit and go back like some others have said, it opens up to my "All Inboxes" inbox, not the iCloud one. Seems like mine is working properly lol
     
  16. macrumors newbie

    Joined:
    Jan 28, 2013
    #16
    icloud defaulting as first email a problem? Here's the solution!

    In ios 6, open the mail app. Go back to mailboxes view. Press edit in the top right. Now rearrange your accounts putting the one you want to be open on app open at the top and vola!
    hope that helps!
     
  17. macrumors 65816

    adam044

    Joined:
    Jan 24, 2012
    Location:
    Boston
    #17
    Just turn off th icloud email thats what I did
     
  18. macrumors 6502

    Joined:
    Mar 11, 2012
    Location:
    Kansas
    #18
    This person is correct.
     
  19. macrumors regular

    Joined:
    Apr 10, 2008
    #19
    This has plagued me since my first iPhone. As best I can tell, no matter what you set as the "default" email for sending emails from your iPhone, iOS always loads the mail account that was added first when setting up the phone. Because alot of us have iCloud mailboxes when you set up your phone and sign into iCloud with your apple ID it automatically adds the iCloud email account. Then you add gmail and set to default but if you restart your phone or force quit the mail app it will always show the iCloud account when you go back into the mail app. It is really annoying to me, especially when you utilize the "All Accounts" feature in the mail app.

    To get around it I believe you can delete all your mail accounts and re-add them starting with your primary gmail account first and you should have that default from now on.

    It is probably at the very very very bottom of the list of fixes apple has to make.
     
  20. macrumors newbie

    Joined:
    Jun 12, 2013
    #20
    Same problem - open Mail and iCloud opens the app.
    I fixed it by editing the order if my four emails so that my private Outlook mailbox appears on top of my business ones
    Next step was to make the default mailbox the same.
    Now I open Mail and my private client automatically opens.
     
  21. macrumors newbie

    Joined:
    Jan 10, 2011
    #21
    I don't think this is correct. Just tried it, power cycled, hit compose email, and iCloud was the default email. I had no idea I was sending email from iCloud until I sent one to myself, then realized I've been sending email from that address for months. So frustrating.

    ----------

    Ok, I figured out how to stop it for my issue:
    Settings/Mail/iCloud Make sure Mail is set to "Off" Somehow it got turned to "On" (not by me!!)
     

Share This Page