iCloud Mobile Documents on Windows

Discussion in 'Windows, Linux & Others on the Mac' started by blackboxxx, Jun 5, 2012.

  1. blackboxxx, Jun 5, 2012
    Last edited: Sep 10, 2012

    macrumors regular

    Sep 10, 2008
    As you all probably know, "Documents & Data" checkbox appears to be missing from Windows version of iCloud control panel, which kind of makes sense, because iCloud document syncing is exclusive to iOS and Mac App Store apps.
    However, all necessary components for this feature are there, including ubd.exe (Ubiquity daemon), so turning this feature on is a matter of tweaking a couple of plist files:

    %AppData%\Apple Computer\Preferences\com.apple.ubd.plist
    kUBSyncEnabledKey = true

    %AppData%\Apple Computer\Preferences\MobileMeAccounts.plist
    • Accounts[0]:Services[where ServiceID="com.apple.Dataclass.Ubiquity"]:Enabled = true

    Here's how to do this:

    1. Open Command Prompt and execute the following commands (right-click to paste into Command Prompt window):
      path %PATH%;%CommonProgramFiles%\Apple\Apple Application Support
      defaults write com.apple.ubd kUBSyncEnabledKey -bool true
      plutil -convert xml1 "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
      write "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
    2. In WordPad window that opens, scroll to the end of the file, find the section that looks like the following and add the bolded lines (note that the url might be different — there's no need to change it):
          <string>Mobille Documents</string>
    3. Save the file and close WordPad
    4. This step isn't strictly necessary, but it will return the plist to its original format: return to the Command Prompt window and execute:
      plutil -convert binary1 "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
    5. Log out (from Windows, not iCloud) and log back in
    6. If you did everything correctly, there should be a new folder "Mobile Documents" under %AppData%\Apple Computer (for example, C:\Users\Username\AppData\Roaming\Apple Computer\Mobile Documents)

    So now you can access all your files stored in iCloud from Windows. To make access to the Mobile Documents folder easier, you can create a shortcut on the desktop or drag it to the sidebar. Everything seems to work exactly the same way as on the Mac side, even the well-known undocumented feature: any files dropped into Mobile Documents folder are synced to all your devices, just like Dropbox does, so you can use this feature to sync files between a Mac and a PC, or between OS X and Boot Camp on the same machine. It even recognizes your other devices on the same network and transfers files between them locally to save bandwidth.

    Warning: this feature is probably not user-accessible for a reason, and most likely it hasn't received the same amount of testing as the Mac version, so don't blame me for any bugs or crashes, or if all your documents stored in iCloud suddenly vaporize. Also note that if you log out of iCloud control panel or change any settings you'll have to repeat the above steps to enable Mobile Documents again.
  2. macrumors member

    Jun 4, 2012

    Great tip man! Have been wanting for such a long time, thanks a million!

    Now let's just hope Apple makes a official and prettier solution. :)
  3. macrumors newbie

    Jun 17, 2012
    It did not work

    Hi, i really want to be able to sinc to icloud directly from windows, but i did what you said many times and it did not work. The mobile documents folder is never there.

    I have win 7, does it work with windows seven or is there something else wrong???
  4. thread starter macrumors regular

    Sep 10, 2008
    It definitely works on Win7, I tested on a fresh install.
  5. macrumors newbie

    Jun 17, 2012
    Why would you think t doesnt work for me. I did exactly as you said and log off windows and nothing, any. Any ideas please????

    I really need this, thank, up front.
  6. macrumors newbie

    Jun 18, 2012
    Mobile Documents Folder Missing

    @Blackboxxx, My macbook is too old to be upgraded to Lion. So I was ecstatic when i stumbled upon your solution which is my only option to run iCloud on XP. I followed all the steps that you have provided on Win XP. I even installed iCloudXP.msi. But, the "Mobile Documents" folder is missing. Should i create this folder manually? I confirmed from XP task manager that ubd is running.

    Please help.
  7. macrumors newbie

    Jun 17, 2012
    I tried creating the folder, it didnt work either.

    Anyone help please!!!!
  8. thread starter macrumors regular

    Sep 10, 2008
  9. macrumors newbie

    Jun 18, 2012
    @Blackboxxx, iCl


    @Blackboxxx, iCloud does work on XP. See http://clarinerd.com/blog/software/icloud-for-xp/
    Am I missing something? Do I need a MobileMe account in order to get it working?
  10. thread starter macrumors regular

    Sep 10, 2008
    Ok, now I see that it's possible to install iCloud on XP by modifying the msi file. But note that the commands I posted use environment variables (such as %AppData%) that might work differently on XP, so try to substitute the full path (e.g., "C:\Documents and Settings\<Username>\Application Data").
    Also, killing all iCloud-related processes before modifying the plist files might be a good idea.
    Ubd.exe running by itself is not an indication that mobile documents are enabled, because it runs on startup by default.
  11. macrumors newbie

    Jun 17, 2012

    i could use a little help too, i am using win 7 32 bit, and there is just no way the mobile documents folder come out, i even try what you said here and killed with task manager ubd.exe and all the processes related to it, an did the procedure then log off anb back but still nothing. Any ideas please!!!!!
  12. thread starter macrumors regular

    Sep 10, 2008
  13. macrumors newbie

    Jun 17, 2012
    Yes of course i have icloud panel control and alwas sign in.
  14. macrumors newbie

    Jun 17, 2012
    So i guess i wont have mobile documents in win after all?
  15. macrumors newbie

    Jun 17, 2012
    it seems this web page is just about rumors after all and not real facts. :confused:
  16. macrumors newbie

    Mar 21, 2012
    I see there hasn't been a response in a small while, but have any of you Windows users who aren't seeing the file solved this? I stumbled upon this post and was disappointed to find it isn't working for me.

    I'm having the same problem. I've tried following all the suggestions and still don't see the folder. I'm running Windows 7 32-bit.
  17. macrumors newbie

    Sep 10, 2012
    spelling mistake?

    it definitly works on windows 7
    there seems however to be a spelling mistake in the Guide. I had to add the following lines to the com.apple.ubd:
  18. thread starter macrumors regular

    Sep 10, 2008
    Thanks for spotting my mistake, AntiCat. I've updated the instructions.
  19. macrumors newbie

    Jan 27, 2009
    Can anyone confirm if this works on the new iCloud 2.0 Control Panel for Windows that came out with IOS 6?
  20. blackboxxx, Sep 21, 2012
    Last edited: Sep 21, 2012

    thread starter macrumors regular

    Sep 10, 2008
    It no longer works with iCloud 2.0 because the Ubiquity daemon (ubd.exe) has been removed. Somebody at Apple must have seen this thread.

    So if you need this feature, you can stay on version 1.1 and it should continue syncing with iOS 6 just fine — the only significant addition in version 2.0 is support of shared photo streams.

    If someone wants to experiment further, it might be possible to transplant ubd.exe and missing dll's from previous version, but this will likely require more effort than it's worth.
  21. macrumors member

    Jan 2, 2009
    Installed iCloud 1.1, followed the instructions after finding the directory manually (First command doesn't return the correct path change for me Win 7 x64)

    Everything seemed to go OK, but no MobileDocuments folder for me
  22. macrumors newbie

    Nov 9, 2012
    When I open the "MobileMe Accounts.plist" (in WordPad window), I can't find any section that looks like the one that you put on step 2.

    The only part of the text that refers to "MOBILE DOCUMENTS" is this:

    \DU]^_WEnabled _com.apple.Dataclass.MediaStream\Photo Stream_Dcom.apple.Dataclass.MediaStream:405E4610-ECE8-584C-B725-594524948D5A_"https://p04-streams.icloud.com:443Õ!=P?aDUbc_com.apple.Dataclass.Ubiquity_#https://p04-ubiquity.icloud.com:443_Mobille Documents ViCloud"

    This part is near the end of the document.
    After that comes a series of characters that don't appear in the text of the forum.

    I am using iCloud 1.1.

    Help me.
  23. thread starter macrumors regular

    Sep 10, 2008
    It looks like you didn't convert that file from binary into XML plist format (that's what 'plutil -convert xml1 ...' does).
  24. macrumors newbie

    Feb 6, 2008
    change dir first


    cd "C:\Program Files (x86)\Common Files\Apple\Apple Application Support"

    and make sure you leave a new line between true and plutil
  25. macrumors newbie

    Jun 3, 2013
    It does not work!

    Hi everybody, somehow it does not work on my win 7 PC.
    I have icloud 1.1 installed.
    When I open command and I paste the first line nothing happens as you can see below:

    Microsoft(R) Windows DOS
    (C)Copyright Microsoft Corp 1990-2001.

    C:\USERS\TOMHOU~1>path %PATH%;%CommonProgramFiles%\Apple\Apple Application Suppo
    Too many parameters

    C:\USERS\TOMHOU~1>defaults write com.apple.ubd kUBSyncEnabledKey -bool true
    DEFAULTS is not recognized as an internal
    or external command, operable program or batch file.

    The system can not find the specified path.


    what do I wrong???? please help!

Share This Page