Icons Missing On Top Of The Screen

Discussion in 'OS X' started by igotamacboook, Oct 23, 2010.

  1. macrumors newbie

    Oct 23, 2010
    i've got a problem,
    all the items/icons on the top right hand corner of my macbook pro are missing
    i don't know what happend
    and i now want to switch to my other account and i'm unable to do so because of this incident

    does any one know how to solve this?

    i already tried to download butler two times-- i thought maybe i could use that to switch over but butler isn't responding despite having been successfully downloaded.

  2. Guest


    Sep 7, 2008
    forlod bygningen
    Which exact Mac OS X version do you have?
    And what have you done short before the missing icons happened?

    Btw, you mean the icons in the Menu Bar on top, don't you? If so, have you taken a look at System Preferences > Time & Date or Bluetooth or Network or Accounts and see, if you can bring the icons back?

    Can you maybe post a screenshot? (Shift + Command + 3 > Preview > Crop (Command + K))

  3. thread starter macrumors newbie

    Oct 23, 2010
    i have gone to that section but how do you bring em back?
    there's like nothing up there anymore; no account icon/date/clock/network/battery... nothing

    it is a macbook pro 10.4.11
    and i'm not sure what i did that caused this
  4. macrumors 68040


    Jan 25, 2009
    A couple of examples:

    • Go to System Preferences
    • Go to Date & Time
    • Go to the Clock tab
    • There is a checkbox next to Show the date and time put a checkmark in it.
    • Under that are options for where and how the clock appears set them as you like.

    Fast User Switching
    • Go to System Preferences
    • Go to Accounts
    • Click on Login Options at the bottom of the list of users. If Login Options are dimmed out, click the lock icon and type the administrator name and password.
    • There is a checkbox next to Enable fast user switching put a checkmark in it.
    I don't have the other options that you're using as I'm on a desktop iMac but in the System Preferences for those other items, you should have an option to check or un-check for show in menu bar or wording to that effect. HTH
  5. macrumors 601

    May 22, 2008
    Milwaukee, WI
    /System/Library/CoreServices/Menu Extras

    Go there ^

    Double-click the ones you want.

    Get rid of one: Command-drag, release

Share This Page