Idiot proof instructions for ClamXav needed

Discussion in 'Mac Apps and Mac App Store' started by rorymilli, Dec 4, 2006.

  1. rorymilli macrumors member

    Joined:
    May 25, 2006
    Location:
    France
    #1
    Hello There, I decided I'd better download ClamXav as I run Microsoft Office for Mac (just for Entourage). I thought I'd followed the instructions but I'm just going round in circles. Here is what I did:
    Downloaded latest ClamXav_1.0.6
    Opened .dmg file on desktop
    Dragged icon for ClamXav onto icon for Applications (as indicated by big black arrow)
    Opened instructions "How to install plugins" and followed directions about creating folder for Contextual Menu Items in Home/Library.
    Dragged 'ScanWithClamXav.plugin' into folder. Clicked on ClamXav icon in applications and did the install thing (agree to licsence etc)
    Logged out and in again.
    Clicked ClamXav in Applications and just got the install thingumybob again. I'm just going round in circles.

    I opened finder and this it what it tells me it has found for ClamXav:

    Downloading and Installing ClamXav.doc (iMac info)
    ScanWithClamXav.plugin (Contextual Menu Items)
    ClamXav (Applications)
    uk.co.markallan.clamxav.plist (Preferences)

    It looks like it is all there - how do I get it to work? Thanks
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    First, regarding the plug-in...I was confused about this, but I think it actually goes in /library and not ~/library. Or at least I found that the contextual menu items folder was already there when I looked in the other location. But that shouldn't stop Clam from working.

    But I wouldn't think that would mess up your install.. that's just to have a "scan with Clam" option in the contextual menu.

    Mmmm, so something else is wrong. Most likely, something involving ClamXAV's ability to get ClamAV (X is just a front-end for ClamAV, which is the actual engine).

    When you run Clam and you get the install prompts...does it *work*? What kind of account is the account you're doing this with (admin, standard, etc)?
     
  3. rorymilli thread starter macrumors member

    Joined:
    May 25, 2006
    Location:
    France
    #3
    Hello There, I presume my account is just a standard one. It's my computer and I was asked to put in my password as I am the admistrator. I have just tried to open ClamXav. I went to Applications and clicked on it's icon. it bounced in the dock and came up with an installation screen. It says "before using ClamXav you must install the Clam Anti-Virus engine. Click the 'Install' button to do this now - the installer will launch and ClamXav will quit. This is the screen I have had lots of times. I click install and do all the box clicking when prompted. it then tells me I must log out and in again. I do this and I'm back where I started (Hence the title of the post). Any ideas? Thanks
     

Share This Page