iDVD won't import .m2v file

Discussion in 'Digital Video' started by macaddict23, Dec 17, 2012.

  1. macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #1
    I exported a .mov from Final Cut Pro X using Share > "Master file (default)" setting. It looks great, but the file size is fairly large. So I imported the .mov file into Compressor using the preset settings "MPEG-2 for DVD" and "Dolby Digital Professional."

    Then, I tried importing the .m2v file into iDVD, but iDVD can't read it.

    My goal is to have the highest video quality at the smallest file size possible. Is there any way for Compressor to compress a .mov and export it as a .mov?

    Thanks.
     
  2. macrumors demi-god

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #2
    iDVD will only burn MPEG2 files it creates so you should be able to export from FCP, then import that file into iDVD if you want to make a DVD. It won't be the best quality at the smallest file size as iDVD doesn't have controls for fine tuning that sort of thing.

    Compressor can certainly import a MOV and export a MOV you just have to choose settings that allow MOV to be the container.
     
  3. thread starter macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #3
    I tried a drag-and-drop of the .m2v file from into the an iDVD project window, but that didn't work.

    Would you happen to know which settings? I'm more of a print designer, and so video is a whole new ball game for me.

    Thanks!
     
  4. macrumors demi-god

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #4
    Sorry I wasn't clear. Try using the MOV from FCPX.

    There's a bunch really, ProRes, H.264, Animation, DV, HDV... each with different uses. For example if you were looking to make a high quality, master export ProRes would be a good choice but if you were looking to make an export to upload onto YouTube then H.264 would a way to go.


    Lethal
     
  5. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #5
    You have to differentiate between the container (.m2v or .mov) and the used codec of the streams inside. The latter determines your filesize and quality, the container only wraps up all the data into a file. For more info on this, I made this animated video explanation. And you can easily (and fast and losslessly) change the container from .m2v to .mov with this little tool I programmed.

    But that's all missing the point: Like Lethal said, iDVD will re-encode your video anyways, no matter in what format you import it. And you can not really do much about the settings it uses. So there are two ways to go at this: Either you look for a more advanced DVD authoring program, but I don't really know of a good (and cheap) one. Or you should just export your video with a big filesize but very good quality. The filesize will be reduced by iDVD anyways and it's better to start this with as good a quality as possible, not already a DVD-encoded file.

    So: Export as "ProRes" or "Apple Intermediate Codec" and use this file in iDVD. It will be way too big, but iDVD takes care of that and compresses it for you.

    Good luck!
     
  6. thread starter macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #6
    Truly appreciate the help!

    One more question about iDVD. I burned a DVD, but I don't want it to automatically launch in fullscreen mode once the DVD starts playing.
     
  7. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #7
    That's not a setting of the DVD but of the DVD-Player. In Mac OS X, you can just start the DVD Player and go to the Settings (Cmd+,). The very first option on the very first tab should be something like "On startup: Change to full screen mode", which you can uncheck.

    Have fun!
     
  8. thread starter macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #8
    Thanks again.

    My end goal is to create hundreds of copies to sell. That would probably mean exporting the project as a disc image, which a print shop will then make multiple copies of. I don't want the movie to auto play at fullscreen because it's blurry.
     
  9. macrumors 68030

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #9
    Are you talking about the dvd automatically playing when inserted in the player? If so, then in iDVD's case, the above is incorrect. With an iDVD Project window open, click on the Map View and delete the contents of the first box, as below:

    [​IMG]
     
  10. thread starter macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #10
    I'm talking about NOT wanting it to automatically go into full screen mode after the DVD is inserted.
     
  11. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #11
    Like I said before, you can not set this on the DVD. It is set on the computer you are playing it back. If you want to distribute the DVD, there is no way of preventing it. Sorry. The "auto fullscreen mode" setting is in Mac OS X's "DVD Player" software.

    If you only want to play it back on your own computer and prevent the automatic fullscreen, follow the steps I described before. (the exact names of the menus and fields may vary, since I only translated this from my German version... :) )
     
  12. thread starter macrumors 6502

    macaddict23

    Joined:
    Jun 20, 2006
    Location:
    MacVille, USA
    #12
    floh,

    Yes, it made sense the first time. Thanks!

    I was simply trying to clarify with my intent with Dave.
     

Share This Page