IE problems

Discussion in 'Mac Basics and Help' started by Karl Gucklhorn, Dec 21, 2005.

  1. Karl Gucklhorn macrumors newbie

    Joined:
    Dec 18, 2005
    #1
    Recently, Internet Explorer has stopped displaying 'Helvetica'. Any text in this font is nonsense. Any ideas anybody?
     
  2. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #2
    First thing I did with my Mac was to drag IE into the trash.

    It's an awful browser, try Safari or Firefox instead. Safari is great, it comes with your Mac and kicks IE's arse for standards compliance and the built-in RSS reader is very handy.

    Firefox is free and also very good.

    But yeah, stop using IE, it's a cancer on the web and MS no longer supports the Mac version, Apple no longer include it with Macs and no Mac user really uses it anymore.
     
  3. jadekitty24 macrumors 65816

    jadekitty24

    Joined:
    Oct 19, 2005
    Location:
    The poor section of Connecticut
    #3
    IE??? What the hell is IE???
    *wink-wink-nudge-nudge*
     
  4. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #4
    Say. No. MORE!!! :D
     
  5. Deepdale macrumors 68000

    Deepdale

    Joined:
    May 4, 2005
    Location:
    New York
    #5
    I'm still using it with OS 9.1, but it is more problematic than it is worth (freezing up and no new thread option available to me on this forum). Safari will be a most welcomed relief.
     
  6. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #6
    You can't run iCab or Netscape? iCab still have a 68k browser available so I'd imagine they have one for OS9.
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    What do you mean by nonsense. Does it look like Sanskrit? How about a screenshot?

    This happened to my girlfriend a while back, and was because she'd installed a font pack with an Indian font named something similar to Helvetica (or might even have been Helvetica something) and that "took over" for Helvetica Regular.

    It can also be that one or more fonts have gone corrupt.

    A couple of possible fixes: Run Font Book and mark all fonts and try File -> Validate Fonts and File -> Validate File and Edit -> Resolve Duplicates.

    Also, have you've tried some of the obvious things, like looking in IE preferences for default fonts, seeing if it works in another user account (make one if you have to), deleting the IE pref file, repairing permissions, restarting, running periodicals, etc. :)
     
  8. Deepdale macrumors 68000

    Deepdale

    Joined:
    May 4, 2005
    Location:
    New York
    #8
    I took down alternatives about two weeks ago and they just did not install properly, so I discarded them and continue to make do with IE for the time being.
     
  9. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #9
    Fair enough.
     
  10. Karl Gucklhorn thread starter macrumors newbie

    Joined:
    Dec 18, 2005
    #10
    Helvetica problems

    Recently, Internet Explorer has stopped displaying 'Helvetica'. Any text in this font is nonsense. Any ideas anybody?

    Thankyou for your responses.
    I wouldn't normally use IE, but I'm studying web design and need to check my web pages in various browsers. looking into this further, I've found that Firefox has the same problem. More worringly, I'm having the same Helvetica problems when I'm designing in Dreamweaver.
     
  11. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #11

    Sounds like Helvetica the font has become corrupted on your machine. I think Apple has some support documents regarding fixing corrupted fonts. From your description this sounds like a system-wide problem rather than a browser-specific thing.
     

Share This Page