ie6 problem, clicking on input box is selecting the submit button

Discussion in 'Web Design and Development' started by Cabbit, Mar 31, 2011.

  1. macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #1
    Demo http://cabbit.co.uk/public/demo/

    I have a nasty little ie6 problem that has me perplexed to the cause. Every time i click on a input box be it the search one or ether of the 2 in the login area in ie6 it just highlights the input box as if it is active.

    I have tired turning off javascript but this did not help so i assume it can't be a javascript issue. And disabling the stylesheet also had no joy so i can only assume i have messed up basic html.
     
  2. macrumors regular

    Joined:
    Mar 27, 2009
    Location:
    Skipton, UK
    #2
    I don't have a machine with IE6 on so can't see the issue directly. However running your page through the W3C validator shows no errors in the html so it's unlikely to be that. When you say "just highlights the input box as if it is active", what do you mean? This, unless I've misunderstood what you have written, is the default for any browser.

    Can you enter text in to the input box? Any other symptoms?
     
  3. macrumors 6502a

    jbyun04

    Joined:
    Aug 31, 2008
    Location:
    Canada
    #3
    You're going to rip your hair out coding for IE6.. is there a reason you're wanting to?

    Considering that IE6 is being promoted by Microsoft to die I really wouldn't worry about making it compatible, unless your audience is from South Korea where 24% are still using IE6 :p
     
  4. thread starter macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #4
    I mean when clicking on the input box instead of it focusing on the input box for text entry, it instead focuses on the submit button.

    While ie6 is not my target platform since the site worked so far without any alterations i don't mind supporting it.
     
  5. macrumors regular

    Joined:
    Jan 26, 2010
    #5

    IE6 is not very forgiving. If it works in Firefox then you most likely have html error(s)... things like missing close brackets /> and table cell <td></td> can effect that in IE6 where other browsers assume it's there and will still work. Have you tried and html validator?
     
  6. thread starter macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #6
    The HTML is fully valid, i tried it on a couple old dells and it worked on there IE6 so i am assuming it was a problem with the multi ie installation i have on my vm.
     
  7. macrumors regular

    Joined:
    Jan 26, 2010
    #7
    I also have IE6 running on a XP machine that I keep around just for checking some web sites on it. It is a system install not a VM. I checked your link at http://cabbit.co.uk/public/demo/ and it appeared to be OK as well.
     
  8. macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    #8
    When I click the search box in IE6, the submit button does highlight, but I can still type in the text field.

    It might be the button:active declaration in the CSS that IE6 is hiccuping on.
     
  9. macrumors regular

    Joined:
    Jan 26, 2010
    #9
    I just checked again and the "Go" button gets highlighted and I CAN enter text and search. My IE6 was installed automatically with XP Pro.
     
  10. thread starter macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #10
    Well as long as text can be entered i don't mind, its a dying browser i wont put much more thought into it.
     

Share This Page