Ilife '06 won't mount

Discussion in 'PowerPC Macs' started by Artist46, Sep 1, 2012.

  1. Artist46, Sep 1, 2012
    Last edited: Sep 2, 2012

    macrumors newbie

    Sep 1, 2012
    I have a G4 power PC running OSX 10.5.8. My idvd does not run with this system. I thought ilife '06 would update idvd and run on this system. I got the box with 2 dvd's disk 1 and 2 but when I put disk 1 in it gives the message "the software cannont be installed on this computer. My stats are below. The disk says Mac OS 10 and bundeled software. Is this how ilife comes? Does it not come on disk that says ilife '06. Does ilife not run on this system? What do I have wrong?

    17" G4 Powerbook, OSX 10.5.8, 1 GHZ PowerPC G4, 1GB DDR SDRAM
  2. macrumors 6502


    Apr 5, 2012
    London, The United Kingdom
    Seeing as you didn't post any system specs check yours against the official specs:
    Macintosh computer with a PowerPC G4, PowerPC G5, or Intel Core processor.
    733 MHz or faster for iDVD.
    High definition video requires 1 GHz G4 or faster and 512 MB of RAM.
    256 MB of RAM required (512 MB recommended).
    1024 x 768 display resolution

    Also it sounds like your using a software restore disc and this will only be compatible with a mac which it came with, are these disc for your mac??

    I hope this helps
  3. thread starter macrumors newbie

    Sep 1, 2012
    my stats

    here are stats on my computer

    17" G4 Powerbook, OSX 10.5.8, 1 GHZ PowerPC G4, 1GB DDR SDRAM

    No not my system disks. When I updated to osx 10.5.8 my idvd stopped working. I read online that Idvd '06 would work on my computer. I got idvd '06 on amazon and it came open boxed with the above described install dvd's and brochures. Is there another solution to get Idvd to work on my machine? everything else works.
  4. macrumors 68040


    Aug 21, 2004
    IDVD '06 should have come with iLife 06. Not sure why you would have two dvds for it? Can you post photos?

Share This Page