I'm not getting all messages on my iPhone, but they come in on iPad and Mac

Discussion in 'iOS 7' started by felixen, Dec 13, 2013.

  1. macrumors 6502a

    Joined:
    Apr 13, 2009
    #1
    Hi,

    For some reason when I got my 5S and installed my backup copy from my iPhone 5 on it, I started to miss a lot of messages on my phone. I've been in the settings for iMessage and confirmed that I have both my phone number and my email address enabled. But for some reason they still don't come in on my phone. On my friends' devices they now have 2 threads after I got my 5S, and only one of them works for me now. I even tried sending a group message from my 5S, and for one of my friends it landed in the old thread (meaning that when he responded I wouldn't receive it on my phone), while the other friend got the message in the new thread.

    What the hell is going on?
     
  2. macrumors 6502

    Joined:
    Mar 31, 2010
    Location:
    Las Vegas, NV
    #2
    Sometimes I've noticed a delay on my phone receiving an iMessage whereas my mac and my iPad get it first -sometimes at the exact same time. Usually within 30 seconds or so, the iPhone gets it as well....are you experiencing a delay or are messages just not coming through period?
     
  3. thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #3
    I don't get the messages at all, so unfortunately it's not just a delay. I really don't understand this. I don't see what I could do differently in my settings to fix it
     
  4. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #4
    It sounds like the phone isn't registered to use one of the receiving addresses/numbers for iMessage, despite what the settings show. You could try unchecking and then re-checking an address for use with iMessage (which should toggle a "[device name] is now using [address] for [FaceTime/iMessage]" indication on your other devices. I'd also try disabling iMessage, rebooting the phone, and then re-enabling iMessage.

    As an aside, I always set all of my devices to only use my contact number for iMessage. Even if my contacts have my email address in the same contact profile as my phone number, it seems to result in split threads very often. Messages on OS X handles this properly without splitting conversations. It's disappointing that iOS doesn't handle it properly.
     
  5. thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #5

    Worth the shot re-enabling everything. I can't do that with the phone number in settings though (meaning I can't disable my phone number in the iMessage settings. I can only disable my email). I guess that's normal?

    As for only your number for iMessage, I assume you mean you don't enable your email address in the iMessage settings? Do you still receive messages on your iPad then? I'm in my iMessage settings on the iPad now and I can't enable my phone number, so if I start a thread on my iPhone using only my phone number, I don't think it'll come in on my iPad too..?
     
  6. thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #6
    Hmm now the phone number appeared on my iPad after I reset the settings on iPhone. Will try and set it to send and receive on the phone number
     
  7. macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #7
    The last time i was having iMessage issues, I went on all my devices and turned off iMessage(mac, iPad and iPhone). Then re-enabled on my iPhone and waited for it to activate. Then re-enable it on the iPad and mac.

    I use my phone # as my callerID on all 3 devices and have 2 email addresses I can be contacted at as well.

    Also make sure that you are using the same appleID on all the devices. Sometimes your phone may not be signed in at all and will only receive messages at your phone # while your iPad and mac could be signed in and receiving them at your email address.
     
  8. macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Northeast USA
    #8
    Yes, that's normal on the phone. On OS X or iPads you would be able to disable the phone number. The equivalent of unchecking and rechecking the phone number on an iPhone is to disable and then re-enable iMessage.

    Yes, all of my devices (iPads, OS X, iPhone) are set to use my phone number and only my phone number. Apple added a number of other email addresses for usage (iCloud, AppleID), and while the iCloud email addresses could be deleted entirely, the AppleID address needed to be unchecked on each device.

    It wasn't possible for a computer or iPad to use the phone number with iMessage when iMessage was first introduced. The ability to use the phone number with non-iPhones started with OS X 10.8.2 and a version of iOS that I can't remember. It sounds like something was a little weird with your iCloud account if the phone numbers weren't selectable on your other devices previously. Hopefully the reset that you performed will resolve your issues now.

    As a final note (alluding to what swordfish5736 wrote above), I would still suggest completely disabling everything except for your phone number. I tried keeping the email address enabled and setting all devices to start new conversations from the phone number, yet they would still randomly split conversations on other people's devices. I don't know why it happened and it seems like it should be an easy fix on Apple's part. While giving people an email address for messaging and being able to conceal a phone number is a neat idea, it's not worth the frustration that it caused my other contacts. There are no problems using only your phone number for iMessage.
     
  9. thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #9
    Thanks for the great posts everyone. So far I think the issue is resolved. But I have to keep an eye on it and be more conscious when testing to make sure it works like it should now. If it doesn't I'll try and deactivating iMessage on all my devices, and then activate it on my iPhone first, and then proceed to activate it on the other devices.
     

Share This Page