1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

i'm stuck! can't restore on admin-locked-down MBA, no password

Discussion in 'MacBook Air' started by dave22r, Oct 15, 2011.

  1. macrumors member

    #1
    bought an 11 inch macbook air yesterday, the mom locked down kid's account and forgot her password. so the only access i have to the system is on an account that i can't get into the system preferences or really do anything.

    so my question- how do i restore this thing?

    i have an external dvd. stuck a snow leopard dvd in there, restarted, held C, then tried D, tapped C, tapped D, then held or tapped the other 24 letters in the alphabet. i can't get to disk utility. not sure where to go next...
     
  2. macrumors 6502

    #2
    Can't You do Lion Internet recovery?
     
  3. macrumors member

    #3
    it's an older version of snow leopard, no app store, no lion.
     
  4. macrumors 6502

    #4
    But doesn't the MBA have Lion? You should be able to do Restart and then CMD + R to enable internet recover.
     
  5. Moderator

    Nermal

    Staff Member

    #5
    What happens if you reboot while holding Option?
     
  6. macrumors G5

    Consultant

    #6
    Don't buy computers without user account credential.

    You might be buying something stolen.
     
  7. macrumors member

    #7
    Ok, here's one way to take care of this:

    Get your hands on a Snow Leopard instal disk. Hopefully one came with the computer you bought. If no,t borrow one, grab one off ebay of by any other means.

    Find a USB optical drive. Boot from the DVD by connecting the optical drive, inserting disk and booting the MBA while holding down the C key.
    Once booted, as soon as you get to a step in the process where you see a menu bar at the top of the screen, you can select "Utilities" and there should be a password reset function there.

    Also, getting a Snow Leopard DVD and a usb optical drive is kinda a pain in the ass so maybe the 1st thing you should do is contact an apple store and see if they can just take care of it for you. It really only takes a few minutes.
     
  8. macrumors member

    #8
    I have a snow leopard DVD and an external drive. Booted holding C with it plugged in, unplugged, no dice. Just tried holding command. Then command C just for the fun of it.

    Every time I did any of this it goes straight to the login screen. Still scratching my head!!
     
  9. macrumors newbie

    #9
    What about booting from a USB drive? Then you could access the internal drive and be able to reinstall from the DVD.

    That is assuming you have a USB drive that is a clone of a system drive you can access the admin stuff on.
     
  10. macrumors newbie

    #10
    Isn't "option" the key to hold down to boot from another drive, not "c"?
     
  11. macrumors member

    #11
    C is to boot from a CD. neither that or option yielding any results. i'm making a lion USB flash drive now. had to find the one system in my house w/o lion on it and is eligible for the download and it's in work!!!

    hoping that will work :)
     
  12. macrumors member

    #12
    And it didn't work :(
     
  13. macrumors 6502a

    tardman91

    #13
    Buy a new HD and start from scratch?
     
  14. macrumors regular

    Kaylor

    #14
    if this is a rev. E (sandy bridge 2011) macbook air it can't run snow leopard.
     
  15. macrumors 68040

  16. macrumors member

    #16
  17. macrumors member

    #17
    Did you say it has Parental controls on it or a firmware PW?
     
  18. macrumors 65816

    #18
    think its best taking it to an Apple store to be honest. get a genius to fix this issue.
     
  19. macrumors demi-god

    xraydoc

    #19
    Sounds like the firmware password is set.
    You'll need to Google how to bypass that.

    Edit: if you can. The only ways I know require the battery and RAM to come out. Removing the RAM is obviously a problem in the MBA.
     
  20. macrumors 68040

    #20
    https://support.apple.com/kb/ts2391

    Looks like that the only way to get around it is to get Apple to do it.
     
  21. macrumors newbie

    #21
  22. macrumors regular

    #22

Share This Page