iMac 2012 High frequency noise

Discussion in 'iMac' started by iThomas159, Dec 18, 2012.

  1. macrumors newbie

    Nov 30, 2012
    Hi everyone,
    today my new iMac 27" (i5, 3.2 GHz, GTX 680) arrived, but it makes a really loud and high frequency noise.

    Has someone else noticed the same problems?

    Thanks in advance!
  2. macrumors 603


    Open Photobooth and it's gone???
    Try it.
    Or it only happens when the iMac is idle, not if it's working really hard?
  3. macrumors 603

    Oct 14, 2008
    Does it change when you vary your brightness? I experienced some high-pitch noise (capacitor whine?) with earlier iMacs, when below maximal brightness.
  4. macrumors 6502a

    Aug 25, 2010
    Opening photo booth cures mine, not a great solution though...
  5. macrumors newbie

    Dec 12, 2012
    I have spent about a week with my 27" and have noticed a ton of noise. I have the whine and a lot of clicking and grinding from the HDD. Last night when I tapped the chin on the left hand side the noise stopped for a bit then started right back up. I came into work today and checked the forums and it seems that everyone is saying they are quiet as a mouse so I called apple support to see what can be done. They need to see what "processes" are running on mine before they do anything further. So I will have to wait to go home and call back in a few hours. :(
  6. macrumors G3

    Apple fanboy

    Feb 21, 2012
    Behind the Lens, UK
    Mines nice and quiet. Thats one of the things I love about it the most. The Fan in my old PC doubles up at the prop shaft on the QE2!
  7. thread starter macrumors newbie

    Nov 30, 2012
    The noise only appears in idle.
    When the cpu is under full loud, the noise is gone.
    PhotoBooth solves this Problem, because it uses the cpu.

    I think we should call Apple to figure out, what they can do!
  8. macrumors 6502a


    Jun 20, 2009
    Good thing years of loud music have destroyed my upper range of hearing. I don't hear anything from mine.
  9. macrumors newbie

    Nov 30, 2012
    Has this got to do with i5 CPU? Seems to me so far two of them registering the noise are with i5 CPUs while those saying its quiet as a mice came from i7s. :confused:
  10. macrumors regular

    Jun 22, 2012
    Mine is super quiet and it's an i5. 3.2GHz, not the base one.
  11. macrumors 65816


    Mar 11, 2009
    Am interested in the cause; my MacBook Pro makes a quiet high frequency sound which varies with processor activity.
    I don't say much about it lest someone retort "wait, you can _hear_ your computer thinking? WTH?"
  12. macrumors newbie

    Jan 30, 2010
    Same i got, and I have the problem. Hmm
  13. macrumors member

    Dec 10, 2012
    I have the i5 as well, and it is very very quiet. My Mac Mini was much louder overall.
  14. thread starter macrumors newbie

    Nov 30, 2012
    So I just called Apple Support.

    They will pick up my iMac for repair!

    So this noise is definitely a Problem!

    I would suggest that, everybody who has the same Problem should call the Apple Support, too!
  15. macrumors regular

    Jun 22, 2012
    675 video card? 1TB Fusion? Those are the options I have (basically the $1999 iMac with 1TB Fusion option, nothing else).

    I have to check the brand of HDD I got to see if that makes a difference.
  16. macrumors regular

    May 21, 2012
    I've been reading this a few times now in other threads, it seems to be the CPU entering a low power state known as C3, if this were a windooze box you could disable this in the bios, I'm not sure how this could be done on a mac though as I'm still waiting for my first ever OSX beast to change from processing :(
  17. macrumors 601

    Jun 29, 2010
    Mine is quiet as hell and its an i5 base model =/
  18. macrumors 601


    Apr 3, 2003
    Whew, glad to hear this isn't just "normal operating specs." I can still hear the whine of my MDD PowerMac G4, and I sold that noisy beast years ago. :eek:
  19. macrumors regular

    Oct 9, 2007
    The more important thing is your should neither need nor want to disable any of the low power states.

    The cause of these sounds is known as coil whine. What's happening, roughly speaking, is that when the CPU enters a certain low-power state, the voltage to the CPU is reduced. Supplying this reduced voltage happens to cause an inductor somewhere on the motherboard (probably in the voltage regulator) to start vibrating at its resonant frequency, with the vibrations creating the whining sound. The inductor shouldn't do this, but minor defects can allow this to happen.

    If your iMac is producing this high-pitch whine and it's loud enough to bother you, there's not much you can do to truly fix it short of replacing the motherboard -- you should just get the machine replaced by Apple under warranty.
  20. thread starter macrumors newbie

    Nov 30, 2012
    I got a temporarily Fix

    As the problem comes from the power saving of the CPU, the fix is just to prevent the cpu to go in the power saving mode!

    To do so, just put this line into the Terminal and the noise is gone.

    sudo nvram boot-args="idlehalt=0"

    The Problem is, that this works just in OSX, if you use bootcamp the problem will still be there.
  21. macrumors 604

    Mar 29, 2008
    That sounds about right. I'm not sure if you have to manually type that (or create a startup adjustment) to have it run on reboot or not.

    I'm surprised that Apple didn't catch this and work with Intel to fix it. I'm so sick to deal of the C3 idle state noises - this issue has gone on for YEARS with Intel's CPUs.
  22. thread starter macrumors newbie

    Nov 30, 2012
  23. macrumors newbie

    Jan 30, 2010
    Great, it actually seems like it did the trick for me after a reboot!

    Can you explain what the command does? and is there another commend to return to original state to check if this is the temp. fix?
  24. thread starter macrumors newbie

    Nov 30, 2012
    This Command is a Kernel Flag.
    Normaly you can enable the power saving again by resetting the NVRAM.
    Or you set idlehalt=1 .
  25. macrumors 6502

    Oct 3, 2011
    Portland, OR
    i suspect that kernel flag is going to always run your cpu at max frequency rather than at lower p-states when idling.. probably not something i'd want for an all in one or laptop... would consider it a temporary fix until i got apple to do something about it.

Share This Page