iMac CRT won't boot b/c of dead battery?

Discussion in 'Mac Pro' started by thehuncamunca, Jun 20, 2006.

  1. thehuncamunca macrumors 6502

    Joined:
    Jul 9, 2003
    Location:
    NJ
    #1
    My iMac CRT has a dead battery. It worked fine before but i put it into storage for several months and then couldn't get it to boot. After taking it apart to make sure the connections were fine, i found that the battery on the logic board was dead.
    Would a dead battery cause the iMac not to boot?
     
  2. Kormet macrumors newbie

    Joined:
    Nov 27, 2005
    Location:
    Where the land meets the sea.
    #2
    Unlikely.

    Have you tried to boot the computer without the battery in? What happenes then? Do you hear the hard drive, fan, start up chime, anything?

    Ideally nothing else should be connected to the computer (keyboard, mouse, iPod, etc) when you try to boot it, in order to narrow down possible problems.
     
  3. FullmetalZ26 macrumors regular

    Joined:
    Jun 12, 2006
    #3
    A lot of older Macs (most of the II series and some desktop Quadras come to mind) would exhibit the same behavior with a dead PRAM battery, some of which would manage to boot if you pressed the Power button a few times in rapid succession. Anyways, some googling turned up a bunch of similar posts on other forms that suggest you should try replacing that battery. It appears to be a "half-AA" lithium battery, which you can probably pick up at Radio Shack for around $10.

    edit - I need one of these as well for my SE/30, so I looked them up. Radio Shack stocks them for $15, and they're also available from Mouser Electronics for around $5, depending on the brand.
    http://www.radioshack.com/product/index.jsp?productId=2104707&cp=2032056.2032141&parentPage=family
    http://www.mouser.com/index.cfm?han...uctid=195423&e_categoryid=165&e_pcodeid=66702
    http://www.mouser.com/index.cfm?han...uctid=422914&e_categoryid=165&e_pcodeid=67205
     
  4. Sutekidane macrumors 6502a

    Sutekidane

    Joined:
    Jan 26, 2005
    #4
    I took out my imac g3 450 battery because it was dead, and it still boots fine and I'm installing 10.2 on it right now.
     
  5. thehuncamunca thread starter macrumors 6502

    Joined:
    Jul 9, 2003
    Location:
    NJ
    #5
    thank you very much-I'm going to try replacing the battery and hopefully that will work :)

     

Share This Page