1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

imac G4 startup problem

Discussion in 'PowerPC Macs' started by aminor, May 5, 2011.

  1. macrumors newbie

    #1
    imac PowerMac G4 circa 2004 running OS 10.5.8. I was upgrading software when power went off, battery backup died and computer turned off. Since then when I try to boot it does not chirp, but goes to apple logo, then to the black "You Must Restart" multi language screen. it will boot in safe mode and run some of my programs, and will boot from backup external drive. When I try to run DiskWarrior or Teck tool Pro I get the message, "can't unmount Macintosh HD, close running programs and try again". I can't find any programs running from the internal drive. I have run what I can from DiskWarrior such as repair preferences, but still same result. Any help appreciated.
     
  2. macrumors 65816

    adcx64

    #2
    zap PRAM and NVRAM. ( google how to do this )
    could possibly be a hard drive failure.
     
  3. macrumors newbie

    #3
    I did zap PRAM, but did not NVRAM. If it was a hard drive problem, would it still do fine with a safe boot running off the hard drive? I was hoping to try rebuilding the hard drive with disk warrior first, but don't know how to unmount it.
     
  4. macrumors newbie

    #4
    I did some things with MacKeeper, trashed dashboard, was shutting down for the night, hit "restart" expecting the same results, but instead got a loud chime and booted up normally. Not sure what the problem was unless it had to do with dashboard. Tomorrow will see if disk warrior can rebuild the drive.
    Thanks. This has been bothering me for six days.
     

Share This Page