iMac G4 USB Issues

Discussion in 'iMac' started by scaart, Dec 27, 2012.

  1. macrumors newbie

    Joined:
    Dec 27, 2012
    #1
    Hi, I have an imac G4, Version 10.4.11. It has been working fine for many years, now all of a sudden, after trying to connect an HD Video camera to the hub, the mouse stopped working. Ever since, every time I start up the mac, the mouse and keyboard wont work, if I reconnect the mouse to the keyboard, both mouse and keyboard will work. If I then try and connect a portable harddrive to the usb hub, the mouse and keyboard will not work again. Please can someone tell me what is going on! Thanks in advance :)
     
  2. CIA
    macrumors 6502

    Joined:
    Jun 17, 2003
    #2
    Seems like there might be a short in the hub. Is it a stand alone hub or the one in your keyboard?
    I'd replace the hub first (they are cheap thankfully).
     
  3. thread starter macrumors newbie

    Joined:
    Dec 27, 2012
    #3
    I have tried a different hub, and have the same problem. I have also started up the mac without the hub connected and still the same problem.
     
  4. CIA
    macrumors 6502

    Joined:
    Jun 17, 2003
    #4
    Does it happen with a different keyboard attached?
     
  5. thread starter macrumors newbie

    Joined:
    Dec 27, 2012
    #5
    Tried a different keyboard as suggested, works fine when I turn on the mac, and the mouse works fine too. Looks like it could be the keyboard that was faulty, so thanks for that :) Only prob now is that the portable harddrive will still not work, the mac just wont see it whether I connect the usb to the hub, or directly to the mac. When connected to a different mac (macbook) it appears straight away and everything on it can be accessed with no problems.
     
  6. macrumors 68030

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    NY State of mind
    #6
    Unless you have the very high end iMac G4, it's USB Bus is v1.1 not v2.0....maybe the external drive controller isn't backwards compatible with v1.1?
     
  7. thread starter macrumors newbie

    Joined:
    Dec 27, 2012
    #7
    How do I find that out? I am currently looking on the system profiler under USB but cant see where it says the version. Just to point out though, the external drive was working fine with the imac for over a year.
     
  8. macrumors 68030

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    NY State of mind
    #8
    I believe the only iMac G4 that had USB 2.0 was the 1.25 GHz model. Anyway, since the drive worked for a year previously, that's not the issue.
     

Share This Page