iMac G5 iSight PSU or logic board faulty?

Discussion in 'PowerPC Macs' started by jtreml60, May 13, 2013.

  1. macrumors newbie

    Joined:
    May 13, 2013
    #1
    Hi, really need some help as I've run out of ideas! Friend asked me to have a look at his iMac G5 20" with iSight as he couldn't power it on. I agreed and after a fair bit of dismantling and troubleshooting, decided it was the PSU and replaced the PSU with one off eBay. I installed the new one tonight but still no joy. I've followed the instructions in the service manual to help troubleshoot and find that none of the LEDs on the logic board light up. When LED1 doesn't even light up, manual suggests the PSU is at fault but it's been replaced and the new PSU is making a faint hum so I know there's at least some juice getting to it. I've also checked the power outlet, power cord, and tried resetting the SMU.

    If the logic board was faulty would I at least get that LED1 lighting up? Is it likely to be the logic board that is at fault now? Any way I can verify that in any other way?

    All thoughts and suggestions welcome. Jim
     
  2. macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
  3. thread starter macrumors newbie

    Joined:
    May 13, 2013
    #3
    thanks for responding. What do I need to look for on the logic board to see if it has bad caps? if it was this would that explain why the power supply seems OK but the first LED on the board is dead still?


     
  4. macrumors 65816

    rabidz7

    #4
    Capacitors that have exploded or are leaking.
     
  5. TUSL2C, May 17, 2013
    Last edited: May 17, 2013

    macrumors newbie

    Joined:
    May 15, 2013
    #5
    LED 1: Indicates that trickle voltage from the AC power inlet to the power supply has been detected. This LED will be ON when the computer is turned off and your power supply is working correctly.

    LED 2: Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

    LED 3: Indicates that the main logic board has established communication with the LCD display.

    LED 4: Indicates a processor over-temperature condition. The system will shut down when this LED turns on.

    As the manual suggests, if there is trickle power but no boot then the MLB is likely faulty
     

    Attached Files:

  6. thread starter macrumors newbie

    Joined:
    May 13, 2013
    #6
    so, had the logic board out this morning and the caps look absolutely fine - no leaking or bloating. Put it back in and reconnected all the wires but still no LED 1 comes on, though can still hear PSU humming.

    Any other ideas or do you think logic board is gone?

    Thanks for all advice thus far!


     
  7. macrumors newbie

    Joined:
    May 15, 2013
    #7
    Is the PSU known to be good and working, If all was well there should be at least trickle power shown by LED 1. You state that the PSU is making a humming noise. That may not be an indicator that it is working. All you can really do at this time is ensure a good connection for both the power supply connector, try and reseat the PSU cables or verify that the PSU is definitely working.
     

Share This Page