iMac G5 - Lost Password

Discussion in 'PowerPC Macs' started by blakeredfield, Sep 2, 2009.

  1. macrumors newbie

    Sep 2, 2009
    Hi guys,

    I have inherited my uncle's computers and I'm having problems logging into his iMac G5 20''. I have the original Tiger Install DVD, I put it in, restart, pressing C, etc but the install DVD doesnt run and I just end up at the login screen.

    He also had an iBook G4 and I used the same trick to change the admin password - it worked just fine.

    Does anyone know why pressing C isnt starting up the install disk? Its the original.

    ALSO: I've read of a workaround using the single-user password reset option that goes as follows:

    - start computer pressing Command-S
    - sh /etc/rc
    - passwd 'Uncle Paul'
    - enter a new password twice
    - reboot

    and thats it... apparently. I'm afraid to do it though, because I need to gain access to my uncle's files before I reinstall. My parents insist of getting all his pictures and stuff (he was also writing his autobiography...) Will doing the above Command-S measure mess with any of his files?

    Thanks guys, I appreciate your help.

  2. macrumors 68040


    Aug 21, 2004
    Are you sure you have the original iMac install DVD or is this a retail Tiger install disc?

    Try the D key instead.

    What iMac G5 is it, anyway? I have the install discs for the 20" Ambient light sensor 2.0ghz. These discs would work for the 1.8ghz 17" iMac g5 as well.

  3. thread starter macrumors newbie

    Sep 2, 2009
    I have an iMac with a large screen, looks like the 20''. Its a G5. I was also given a box of CDs and cables, that included the Tiger install DVD. It worked on the iBook G4 just fine.

    I'll try using the D button when I get home.

    Can you tell me if the single-user passwd reset workaround will destroy the admin home directory (just in case the D button thing it doesnt work?).

  4. thread starter macrumors newbie

    Sep 2, 2009
    * UPDATE: tried it and it till doesnt work. I have no idea why. And I actually used the same DVD to unlock a PowerPC iMac G4 (lampshade mac) that was also one of my uncle's old computers. The nice iMac G5 remains!!!

    Can SOMEONE tell me if the single-user passwd reset workaround will destroy the admin home directory (just in case the D button thing it doesnt work?).

  5. macrumors newbie

    Jul 26, 2009
    Have you tried holding down alt while the computer is booting up, and then selecting the dvd?
  6. thread starter macrumors newbie

    Sep 2, 2009
    OK, good! Something new to try! I''ll give it a shot tonite.
  7. macrumors G5


    Jun 27, 2007
    Sounds like the tiger dvd is older than the computer model, thus won't work.

    You should try to find the corresponding iMac disk.

    Yes try this.
  8. macrumors 6502a


    Apr 27, 2009
    Your Command-S boot into open firmware hack should not destroy your computer. I use a slightly different open firmware hack to open Macs all the time. Give it a shot.

    But yes, start with holding down the "Alt" key during boot. That will give you the choice of bootable devices, it should include the Tiger DVD. Have you also tried booting your iMac into target disk mode into a different Mac (if you have one), and then choosing to install Tiger on the iMac's hard drive via your other Mac? You will definitely have to format the hard drive to install an older version of the OS than is already on there.
  9. thread starter macrumors newbie

    Sep 2, 2009
    The Instal DVD I have says:

    Mac OS X Tiger
    Includes XCode 2
    Install DVD
    Version 10.4

    So it doesnt seem to be too old. I tried some older Leopard 10.2 install CDs and neither of them come up as a boot option, using the ALT trick. I know that Macs never accept older Install Disks than its technology, so thatts not surprising.

    I'm pretty sure that the iMac has 10.4.11 on it, simply because an older iBook G4 he has was updated to 10.4.11 also, so I'd be surprised if his main computer wasn't updated also.

    Thing is, I can hear the DVD spinning, but I cant think why it wont come up pressing the C button, or the ALT method. I'm gonna go 'rent' an external DVD and see if that works, just to eliminate the case that there is something wrong with the DVD itself (unlikely).

    Quantum, if you have a better suggestion on the single user passwd reset sequence, could you please share it with me. If you could explain what every line is also, that would be cool - my unix is kinda rusty.

    Thanks again guys

  10. thread starter macrumors newbie

    Sep 2, 2009
    I bit the bullet after a week of messing around and performed the single-user passwd reset step, I outlined on my first post.

    It worked just fine - Thank you guys.

    PS: My uncle was working on an autobiography - some very interesting stuff about the 60s in there... and apparently had a healthy foot fetish. Pretty fun stuff!

Share This Page