iMac G5 Power Failure

Discussion in 'Mac Basics and Help' started by stevietheb, Aug 18, 2005.

  1. stevietheb macrumors 6502a

    stevietheb

    Joined:
    Jan 15, 2004
    Location:
    Houston
    #1
    Howdy,

    I'm not sure what is going on, but twice this morning my iMac G5 (which has never had any problem before) randomly lost power. The first time, I checked that all the cords were plugged in nice and tight, and then turned it right back on. The second time, it didn't want to turn back on. I plugged the cord into a different socket on the strip, and it worked fine. So, naturally, I thought that that socket must have failed....but it hasn't, I plugged something else in there and it worked just fine (though, it's not pulling as much juice as the iMac...)

    Any thoughts on what might be going on?

    Thanks!
     
  2. wdlove macrumors P6

    wdlove

    Joined:
    Oct 20, 2002
    #2
    Sorry to hear about your difficulty. The best thing might be to take your iMac to the Apple Store to have it checked by a Mac Genius. Hopefully it's just something simple. Better to be safe than sorry.
     
  3. stevietheb thread starter macrumors 6502a

    stevietheb

    Joined:
    Jan 15, 2004
    Location:
    Houston
    #3
    UPDATE: Took the iMac into the Apple Store. About two hours later I had the ol' iMac back with a new power supply.

    Now, however, I'm having trouble running iBackup -- we'll see how this works out...doing hardware test right now.
     

Share This Page