iMac goes to sleep interrupting streaming to Apple TV2

Discussion in 'Apple TV and Home Theater' started by JRoDDz, Dec 11, 2012.

  1. JRoDDz, Dec 11, 2012
    Last edited: Dec 11, 2012

    macrumors 68000

    JRoDDz

    Joined:
    Jul 2, 2009
    Location:
    NJ
    #1
    I am experiencing the following bug: While watching Apple TV2, if my iMac goes to sleep, it will interrupt the home sharing. As a workaround, I have to disable home sharing on the Apple TV2 and then immediately re-enable it to get it started back up. My iMac remains sleeping during this disabling and re-enabling workaround.

    This started happening right after I upgraded to iTunes 11. Anyone having the same issue? Any solutions. I just now disabled the firewall on the iMac to see if that has anything to do with it. But it seems that the sleeping is triggering the disconnect.


    Edit: Just performed this test.. disabled the firewall on the iMac, and so far so good. I do remember having an issue with iTunes 11 asking permission for incoming connections when I initially installed it, but that message went away.
     
  2. macrumors newbie

    Joined:
    Dec 16, 2012
    #2
    I am also having this problem, fortunately my imac is in he same room as the ATV3 setup, otherwise it would be much more irritating.
     
  3. macrumors regular

    Joined:
    Oct 10, 2012
    #3
    Have you installed the 11.01 iTunes update? This solved a disconnect on sleep issue for me.

    Cheers
     
  4. sunday trucker, Dec 16, 2012
    Last edited: Dec 19, 2012

    macrumors newbie

    Joined:
    Dec 16, 2012
    #4
    I am yet to update to .01, didn't realise it was available. I will get on it shortly and report back.


    Edit: just a brief update. Since updating iTunes I have not had this issue, I have not used my atv too frequently this past week, but fingers crossed I'm cured.
     
  5. macrumors newbie

    Joined:
    Feb 7, 2011
    #5
    +1 on the caffeine app. I use it everyday and it's free!!
     
  6. macrumors member

    Joined:
    Dec 29, 2004
    #6
    I was hoping it would help. I'd had to switch my sleep settings to 2.5 hours.
     

Share This Page