iMac Internet Connection Problems

Discussion in 'macOS' started by MacMyDay, Dec 17, 2006.

  1. MacMyDay macrumors regular

    Oct 3, 2003
    Cambridge, England
    I bought an employee a 20" Intel iMac last month so he could work from home now and again, and he's been constantly moaning about the speed of the Internet. So, I went over thinking it would be a simple issue, yet after 5 hours of fiddling about, just could not find a reason for it. I got straight onto his wireless network on my Macbook, without configuring anything, and it automatically connected with no problems at all.

    What happens is that ping times are excellent, and download speeds eventually become full speed, yet web pages load about 90%, then take about 3 seconds to load the final amount, even if it's just 1 image. I was thinking this may be a DNS issue, but the settings are exactly the same on my Macbook as the iMac, and there's absolutely no issue at all.

    Whereas my Macbook will start a download from at 250kb, on the iMac it starts at 5 and works its way up, to eventually reach 250kb. Yet on web pages, it seems to take the opposite direction and load fast, then load slow just before the page is complete - non dependent of browser. Furthermore, typically, on his PC, there are no issues either.

    He's setup on Telewest/Blueyonder with a brand new 20" Intel iMac 2.16GHz. I was thinking it was a DNS issue, but couldn't work out why it didn't need them entering on the Macbook, and then that it was a wireless issue, but why it would eventually get to full speed.

    Has anyone any experience with this and know how to solve it?
  2. Liong612 macrumors member

    Nov 1, 2006
    Try to update the firmware

    If both macs have the same software configuration, then the difference must be in the hardware.. try to get the most updated firmware for the wireless modem and the iMac.
    Some modems don't perform well with new mac computers, i suspect this is because of firmware incompatibility.
    Good luck!
  3. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    One setting I'm not sure you've checked...have you tried disabling IPv6?
  4. MacMyDay thread starter macrumors regular

    Oct 3, 2003
    Cambridge, England
    I can't actually remember if I tried that one, but he's on holiday now. I'll give him a prod in the new year. Thanks.
  5. theBB macrumors 68020


    Jan 3, 2006
    Using WEP instead of WPA might improve things as well.

Share This Page