iMac screen going black for no reason

Discussion in 'iMac' started by Dr. McKay, Nov 15, 2011.

  1. macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #1
    I have an early 2008 iMac (24", 2.8ghz Core2duo, ATI Radeon HD 2600 pro, Snow Leopard).

    A couple of weeks ago, my screen went completely black, for no apparent reason. The Mac was still running but because I couldn't see what I was doing anymore, I had to shut it down using the power button and then reboot it again. Everything was fine after that.

    The day before yesterday, I was browsing the web with Firefox and it happened again. Same thing yesterday, watching youtube clips in Firefox.

    Has anyone experienced this before ? Does this mean my videocard/display is going to die soon ? Should I start worrying ?
     
  2. macrumors newbie

    Joined:
    Oct 22, 2011
    #2
    yes I have the same problem with Firefox, just go to 'options' from 'Tools' under 'General' drop off the check from 'use hardware acceleration when available' . I noticed that card graph has problem with Firefox.

    please let me know if you feel better because I called the apple about this problem, I have Amd 2 gb I face this problem with win7 but now looks fine
     
  3. thread starter macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #3
    Thx, I'll give that a try...
     
  4. thread starter macrumors 6502a

    Joined:
    Jan 20, 2010
    Location:
    Belgium, Europe
    #4
    Screen didn't go blank yesterday. Maybe disabling hardware acceleration in Firefox really did the trick...
     
  5. macrumors newbie

    Joined:
    Nov 20, 2012
    #5
    my brother pointed me to this forum after having this issue. i turned off the hardware acceleration for firefox, but had to enable it in Adobe Flash Player for a game. i'll post an update if i still have a problem.
     
  6. macrumors 6502a

    Joined:
    Jul 12, 2008
    Location:
    Asheville, NC
    #6
    I have an early 2008 24" myself and in the past two months I've had this happen twice and another time the same thing happened but the screens (I've also got an external hooked up) went white instead of black... very frustrating and another reason why I can't wait for the new iMacs to get here

    ----------

    and I do not use firefox by the way... I do however keep chrome (with about 20 tabs), photoshop cs6, safari and a few smaller apps open all day ever day
     
  7. macrumors newbie

    Joined:
    Nov 20, 2012
    #7
    mine is a 2010 and in the past several months i've had this issue. i've brought to the apple store twice already. the 2nd time they did replace the logic board and graphics card. an hour later the screen flickered which is an indication that the screen will go. the next day it did several times. i've used the control-shift-eject combo to bring it back and then it does settle.
     

Share This Page