iMac slow graphics?

Discussion in 'iMac' started by ThatGreekMacGuy, Dec 11, 2012.

  1. macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #1
    Hey guys I installed Windows 8 64bit via Bootcamp. You can see my specs in my signature. For some reason when i run a game (assassins creed or need for speed) the frame rate is REALLT LOW. I get 6-10 fps. My sisters vaio is much worse but runs the game fine. all the drivers are updated. anyone ever had the same problem? what should i do?
     
  2. macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Tried installing the "real" ATi/AMD drivers (from their site) for the grfx card?
     
  3. thread starter macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #3
    Yes I installed the latest ones from amd/ati. any ideas?
     
  4. thread starter macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #4
    Anyone help?
     
  5. thread starter macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #5
    is it a problem with windows 8? do you think that windows 8 drivers might cause it? should i install win 7 x64? does anyone else has a partition of win 8?
     
  6. macrumors regular

    Fried Chicken

    Joined:
    Jun 11, 2011
    #6
    Don't install the graphics from the ATI website, instead use windows updater.
     
  7. thread starter macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #7
    Could this be the problem?
     
  8. macrumors regular

    Fried Chicken

    Joined:
    Jun 11, 2011
    #8
    I spent like 2h trying to get the drivers to work on my imac,
    and it was a pain in the ass involving a bunch of amd bloatware. Finally I did windows update and voila, graphics drivers installed and worked no problem.. Was very impressed with MS at that point, very well done.
     
  9. thread starter macrumors member

    ThatGreekMacGuy

    Joined:
    Jul 12, 2012
    Location:
    Sparta, Greece
    #9
    Everything works like a charm now mate! Thanks!
     

Share This Page