iMac & Wireless problem(Linksys Router)

Discussion in 'Mac Pro' started by Jordan6, May 22, 2006.

  1. Jordan6 macrumors regular

    Joined:
    May 21, 2006
    #1
    ok heres the problem(bear with me lol)..


    i recently just got 17inch iMac(early model)..tiger loaded and erething blah blah.i've had a wireless connection before so i connected with the iMac for the first time last night and it worked perfect. no problem, then after 15-20 mins i noticed the connection kept going in and out.so i just left it there.next morning i try to connect i not only cant connect but i dont even get a signal.im not the smartest in the world about this wireless technology but i DEFINITELY need help.i also re-installed the wireless setup and everything.still cant connect no signal AT ALL.when i try to log in with the correct password it says"error joining network.....can anybody help me out with this?

    I an definitely kinda of a newbie with this(break it down so a 2-ur old could understand, lol)


    thanks
     
  2. tyoelin macrumors member

    Joined:
    Jul 24, 2005
    Location:
    California
    #2

    I have the same problem with my 17" Powerbook with the Linksys WRT54G V 5 router. I spent 1 1/2 hours online with Linksys technical support and 1/2 hour with my ISP and neither group could detect the problem. I sent my computer in to Apple and they could not fix it.

    I've tried every encryption method that the router has, but it seems to only work if there is no encryption at all.

    In addition, I have a PC that can connect wirelessly flawlessly.
     
  3. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
    #3
    one person actually mentioned to me to strip all of the security..and as time wears on add security piece by piece a lil at a time.i stripped it(i think)and same situation no connection.
     
  4. tyoelin macrumors member

    Joined:
    Jul 24, 2005
    Location:
    California
    #4
    EDIT: Or actually the easiest way would be to hold the reset button on the back of the router for 10 seconds and then just let it boot back up again to factory defaults. Look for a wireless network called "linksys"

    Another method: Connect your computer to the router with the ethernet cable. Restart the computer. Go into the System Preferences > Network button. Browse through the windows and make sure that the ethernet connection is activated and connected.

    If it cannot connect with ethernet, I can't help you at all. If it does, open Safari and type in the address bar: 192.168.1.1. Press Go. A window should pop up asking for a user and password. Leave the username blank, and type "admin" without the quotes for the password. Go to Wireless > Wireless Security > and make sure that the connection has no encryption. Also make sure that SSID broadcast is on. Hit save settings.

    That will strip all the encryption off. If you still can't connect, then it is a much more serious problem than what I am experiencing. (Sorry I did all this off the top of my head, the menu directions may not be 100% accurate)

     
  5. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
    #5
    ok, Thanks alot im gonna give it a shot and see what happens......anybody got any other ideas
     
  6. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
    #6
    im trying to connect my Mac thru wireless to a PC thats connected to a Linksys router.
     
  7. tyoelin macrumors member

    Joined:
    Jul 24, 2005
    Location:
    California
    #7
    I have that same setup. My PC is wired to the router, my Pbook is wireless. This is what you do.

    While the finder is open, go to Go > Connect To Server. Type in "smb://192.168.1.XXX/Folder" without the quotation marks where "XXX" is the ending suffix of your PC's ip address locally and Folder is the name of a folder in your root C: drive. This folder must have sharing enabled. For instance, I created a folder in the C: drive called "Mac" so my server looks like this:

    smb://192.168.1.102/Mac

    It will prompt you for a password if you have that enabled. Dont worry about the user name, just enter the password you use for XP. Hope this helps!

    EDIT: This will only work of course if both the Pbook and the PC are both connected to the same network.
     
  8. Jordan6 thread starter macrumors regular

    Joined:
    May 21, 2006
    #8
    That's the thing tho, i cant connect AT ALL.i see the network in wireless so when i try to connect its tells me "there was an error joining network".and that's after re-installing and creating another NEW network/connection.I didnt get a chance to try what you said but im gonna try this afternoon..

    whether it works or not yo man i appreciate the time and help.
     
  9. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #9
    Dumb thought. Could it be that you are actually closer to someone else's network and trying to join that with your password?

    I had a similar problem early on with my iBook where it wanted preferentially to connect to my neighbor's unprotected wireless network than my WEP network...

    Try giving your network a unique SSID that's not linksys or default.

    If you're feeling adventurous you could always try running one of the third party firmwares out there for linksys routers. I use openwrt myself.

    B
     
  10. kevin.rivers macrumors 6502a

    kevin.rivers

    Joined:
    Dec 4, 2005
    #10
    My Powerbook was always finnicky with Linksys routers. I updated the router firmware and it would always get pissed. Only with security though.

    So, i removed security and it worked. I think you said you tried that already.

    I don't have much to add as far as making it connect, it just takes time and lots and lots of patience.

    If you did get it working without security, here are some ways to protect yourself.

    1: Don't broadcast the SSID. This way, only people knowing the name of the Wireless signal can get in. Because it won't show up as an available network.

    2: Lock it down by Mac Address. Connect your computers, then there mac address will be in the router, this way you can have them there and not have to type them in. If you lock down by MAC address, only computers who are in the approved list will be allowed.

    Hope that helps you. This is what I had to do to get my Powerbook on the network. It sucked but it go the job done.

    Good luck to you.
     
  11. outlawdesign macrumors newbie

    Joined:
    May 26, 2006
    #11
    How does one remove security?
    I get an intermittant wireless and ethernet signal from my WRT54G to both my powerbook and my imac, so I get bumped off the web every 5-30 minutes. If I unplug and then replug the router's power cord, Airport automatically reconnects until the next time I get bumped.
    I have spent oh so much time and $ trying to figure this out. I have followed every piece of advice from Linksys tech support: I replaced my cordless phone with one on a higher frequency than the router, replaced the router, reconfigured the router with the current update, replaced my 6' ethernet cord with a 25' ethernet cord. Nothing works.
    Linksys assures me that their router is Mac compatible. Apple tells me to ditch it and get an Airport router.
    I would appreciate any suggestions.
     
  12. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #12
    Removing secirty just means unchecking the boxes for WEP and/or WPA.

    You could also consider running third party firmware on your WRT as long as it's V4 or earlier. Personally I use openwrt, since the iMac was not able to connect to the Verizon supploed Westell 327W at all.

    Not broadcasting SSID and MAC filtering are (IMHO) false sense of security since it is easy enough to discover SSIDs and MAC addresses by examining the packets going from authorized hosts to the wireless access point. There are plenty of wardriving tools that make this easy. If you want to run a network without security, just leave it open.

    B
     

Share This Page