images and pictures in Safari

Discussion in 'Mac Basics and Help' started by galloman, Aug 12, 2006.

  1. galloman macrumors member

    Joined:
    Jul 22, 2006
    Location:
    Monterrey, Mexico
    #1
    Hi all,

    I'm still new to mac and have noticed that when I open pages with a lot of pictures in them, like when I log in a forum where users upload posts with images.

    My Safari browser does not display them all even after the address bar is not blue anymore. I usually have to reload the page several times to see them. What is this due to? can I fix this problem? if so, how? Curious thing is that when I'm on my PC the images just display properly so I guess it has to do with some setting.

    thanks in advance
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Can you give us an example of a site where this happens and maybe a screen shot too? Do you have Display Images checked in the Appearance pane of Safari's Preferences? :)
     
  3. galloman thread starter macrumors member

    Joined:
    Jul 22, 2006
    Location:
    Monterrey, Mexico
    #3
    sure I can give an example

    I was browsing on this forum,
    http://forums.timezone.com/index.php?t=msg&th=676170&start=0&rid=12364

    and on my pc there are 24 pictures showing, whereas there are only 12 on this mac. The rest are just ?s and we are using the same internet connection, so I guess that can't be it. thanks

    screen shots I know not how to do them so I can't do that
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    They all loaded for me. Maybe try resetting Safari from the Safari menu. :)
     

Share This Page