Resolved iMessage Does Not Work

Discussion in 'OS X Mountain Lion (10.8)' started by modit, Aug 12, 2012.

  1. modit, Aug 12, 2012
    Last edited: Aug 13, 2012

    macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Canada
    #1
    I've tried to send an iMessage from my iMac running Mountain Lion to my iPhone and it's not working for me. I haven't received a single text on my iPhone from a Mac.

    The iMac's messaging app shows me offline despite having my iPhone associated with an iCloud. Both sides use @me.com address.

    Any ideas?

    Thanks!
     
  2. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #2
    Make sure both devices are set up using the same accounts.

    [Messages] -> [Preferences]

    Make sure you have all the addresses that you wish to receive from in this list. (Red Arrow).

    *I've whitened out my details*

    On your iPhone/iPad the same settings are under [Settings] -> [Messages] -> [Receive At]
     

    Attached Files:

  3. macrumors 6502

    Joined:
    Jun 6, 2010
    #3
    so people who imessage my phone number, it won't send to my comp?

    it seems like i have to start the convo from my mac to keep it going between both phone and mac...
     
  4. macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #4
    Until iOS 6 yes
    It has to be sent to your Apple ID not your phone #
     
  5. macrumors 6502

    Joined:
    Jun 6, 2010
    #5
    ah ok...a bit disappointed by mountain lion thus far then.

    i feel like battery is noticeably less.
     
  6. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #6
    I've just told people who have iPhones/iPads to stop sending messages to my phone number. I give them my iCloud ID and tell them to use that. It works just as I expect.

    Though, it will be nice when iOS 6 is out so I can integrate my phone number as well.
     
  7. thread starter macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Canada
    #7
    Well I've tried what you said and it's not working (not receiving messages on my iPhone).

    Any other suggestions :(
     
  8. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #8
    You need to make sure the address your sending to is setup on your iPhone's messages settings. It will work if you set that up.

    ie. setup iPhone to receive at xyz@gmail.com. Send an iMessage to xyz@gmail.com.

    Your iPhone will get the message.

    If not, then you haven't set it up correctly.
     
  9. macrumors regular

    Joined:
    Nov 4, 2011
    #9
    Not sure but I don't think you can send an iMessage to yourself.
     
  10. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #10
    Sure you can.

    I have my mac and iPhone set up to receive at the same 4 addresses. If I send to any of them, both my mac and iPhone receive it.

    It actually gets posted twice on my devices. Once as the sender and once as the receiver.
     
  11. thread starter macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Canada
    #11
    I think I have. I have receive at 2 Addresses on my iPhone: My phone number and my @me.com address.

    On my Mac, my preferences state that I can be reached at my @me.com

    I'm running 5.1.1 on my iPhone.

    Any other ideas?

    I'm willing to work this out :(
     
  12. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #12
    Well if you only want to send your phone a message you can send it to your phone number from your Mac.

    Try adding another email address to both your Mac messages and your iPhone.

    Or send a message to your @me.com address from your phone. Your Mac should get it if it's setup properly.
     
  13. thread starter macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Canada
    #13
    Forgive me but I just found out my problem :eek::eek::eek:

    The account I was trying to send messages from my iMac (a family member's @me.com account) was NOT enabled. I simply turned it on and sent a text to my iPhone and it now works.

    Thanks Icy1007 and everyone else helping me troubleshoot this issue.

    Greatly appreciated!
     
  14. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #14
    Yep yep. No problem.
     

Share This Page