iMessage for phone number not active

Discussion in 'iPhone' started by sohanangal, Nov 25, 2012.

  1. sohanangal macrumors member

    Joined:
    Sep 24, 2012
    Location:
    India
    #1
    Hi,

    I am using the iPhone 5. However, my iMessage is not active on my phone number. I receive the messages sent to my Apple ID, but the ones sent to my number are sent as text messages. Also, I do not even get an option of enabling it...I was under the impression it is activated automatically, as it works everyone else in my family. Please let me know! Thanks!
     
  2. JayLenochiniMac macrumors G4

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #2
    Do you have your iPhone number listed under "You can be reached by iMessage at:" in addition to your Apple ID email? This is found under Settings > Messages > Send & Receive.
     
  3. sohanangal thread starter macrumors member

    Joined:
    Sep 24, 2012
    Location:
    India
    #3
    It is not listed! I saw on other phones and it is listed by default. I tried disabling and re-enabling iMessages. It is not working!
     
  4. JayLenochiniMac macrumors G4

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
  5. sohanangal thread starter macrumors member

    Joined:
    Sep 24, 2012
    Location:
    India
    #5
    By restoring you mean setting it up again from factory settings?
     
  6. JayLenochiniMac macrumors G4

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #6
    First make a backup and try restoring from the backup. If still no go, restore as new. If the problem is fixed, your backup is corrupt.
     

Share This Page