iMessage Trouble

Discussion in 'iPhone' started by cobber3, Feb 14, 2013.

  1. macrumors newbie

    Apr 18, 2012
    My imessage on my IP4s isn't working correctly. When its on, it sends to the recipient but instead of my contact name in their phone, my email appears instead. If anyone could tell me how to get it so my email address doesn't show up that'd be great!
  2. macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Are you on 6.1.1? Jailbroken?

    Try a DFU restore see if the problem goes away.
  3. macrumors 6502a


    Dec 23, 2012
    Turn off Wifi.
    Go into "Settings"
    Turn OFF Wi-Fi
    Turn off iMessage
    Turn off FaceTime
    Go into "Settings"
    Find and enter the "General" Tab
    Scroll Down and enter the "Reset" tab
    Click on the "Reset Network Settings"
    It may or may not ask you for a password, just use the same password again you use to get into your iPhone
    After you pressed "Reset Network Settings" Your phone should have automatically restarted.
    NOTE: DO NOT SIGN INTO WIFI, From now on until your "iMessages/Facetime" Works, You should be running on "3g or 4g" internet
  4. macrumors 68030


    Nov 20, 2008
    Go to iMessage settings, there will be a setting that states "Start new conversations from:"

    You can change it to a phone number if you have one set up. Otherwise just tell them to add that specific email to their contact of you and problem solved.

    This has nothing to do with network settings. You don't need to reset it or restore your phone, don't waste your time. You merely need to have them add your email to their contact of you, or change your outgoing message setting.
  5. macrumors 6502a


    Sep 9, 2008
    Las Vegas
    Go to Settings > Messages > Send & Receive. Make sure your phone number is checked under "Start new conversations from."

    If that does not work, try turning iMessage off and then back on.

    EDIT: Mlrollin beat me to it.
  6. macrumors 65816


    Apr 5, 2010
    Houston, TX
    an easier solution is to check your iMessage caller id and check your message settings to see what's selected under "start new conversations from"

    staccato83 beat me to it
  7. thread starter macrumors newbie

    Apr 18, 2012
    Sorry about that guys I have an IP4 not 4s and i'm not seeing the to "start new conversations from" in my imessages. Any other ideas? Thank you for your help! :D
  8. macrumors 6502a


    Mar 22, 2009
    What version of iOS do you have installed?
  9. thread starter macrumors newbie

    Apr 18, 2012

Share This Page