iMessage waiting on activation?

Discussion in 'iOS 6' started by ben824, Jul 16, 2012.

  1. ben824, Jul 16, 2012
    Last edited: Jul 16, 2012

    macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    GA
    #1
    I am running iOS 6 beta 3 on my device and read where some have tried different methods to try and get the whole unifying phone number and apple ID thing to receive iMessage on all devices as well as the other features that come along with it. I have Lion on my MBP and the beta iMessage for Mac. I read where someone tried turning iMessage completely off and logging out on all his devices and then logged back in one by one and got it to work. I tried this with no positive result. iMessage on my Mac still shows only coming from my Apple ID associated email address and not my phone number so those who receive it receive messages in a completely separate conversation. I am attributing my troubles to the fact that I am using the beta iMessage for Mac but I now have a interesting issue on my iPhone 4S.

    When I tried to reactivate iMessage on my iPhone it came back asked for my password, which I entered correctly, and it seems to be working, however it still says "waiting for activation."
    [​IMG]

    Also under "Send & Receive" it shows only my apple ID email address and when I tap on it, it shows both the email address and my phone number but there is only a check mark next to the email address and not my phone number and won't let me check mark the phone number as well. Which I find odd since under a similar menu in the FaceTime settings both are check marked.
    [​IMG]

    So does this mean my phone is only sending iMessages out using my Apple ID email address? Or is my number not checked marked since it is coming from my iPhone and it is already defaulted to send using the number and it just check marks the email address I want to use for iMessage?

    Again like I said before the only reasons I am puzzled by this is because under FaceTime settings both are check marked and it is still says "waiting on activation."

    Update: I used my Mom's iPhone and just deleted my contact and conversation out of her phone and tried sending a message to her phone from my phone and it showed it coming from my Apple ID email and not my phone number!
     
  2. macrumors 6502a

    Joined:
    Apr 7, 2012
    #2
    Give it time, I tried the same thing today and had the same issues, could no longer select my phone number and iMessages was sending from email instead of phone number. I reset my phone a couple of times, and then after about an hour it changed back and worked like normal, then my number came up on my iPad as well.
     
  3. macrumors 65816

    penajmz

    Joined:
    Sep 11, 2008
    Location:
    New York City
    #3
    Having the same problem! Activation doesnt complete on my phone number but my Apple ID works fine. Ahhh! Help!
     
  4. thread starter macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    GA
    #4
    Well I just screwed myself. I thought I would just revert back to Beta 2 and restore from the update I made that would keep iMessage settings as they were. Well I am a but not in a paid program yet I just installed iOS 6 through the backdoor way that has been discovered to install iOS 6 on a non-developer device. Well turns out once a beta become old and there is a new beta out then it will not longer let you install the old beta on a non-developer device. So my backup is no good. I do have my most recent backup from 5.1.1 so I am not totally lost but any data I had built up over the past 15 days is gone but that really is just my text messages.

    So now if I want to go back to iOS 6 I need to find the ipsw file for Beta 3 and reinstall.

    Thats what I get for being impatient.

    Now I just need to find the Beta 3 ipsw which doesn't seem to have been leaked for download yet. If anyone knows where I can get it let me know.
     
  5. macrumors 65816

    penajmz

    Joined:
    Sep 11, 2008
    Location:
    New York City
    #5
    All you had to do was a reset of network settings, just fixed mine that way.
     
  6. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    That just worked for me as well. Thanks.
     
  7. macrumors newbie

    Joined:
    Jan 28, 2010
    #7
    Same.... not working for me either. Help!!
     
  8. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #8
    Did you try what penajmz suggested above? Reset Network Settings.
     
  9. macrumors member

    Joined:
    May 18, 2012
    #9
    Apple support page -- iOS Troubleshooting Messages

    iMessage registration validates your Apple ID for use with iMessage. If you are unable to activate iMessage, try the following:

    [...] . If you encounter issues registering or using an Apple ID account:

    *Ensure you have an active Internet connection.

    *Verify that you are using a valid Apple ID at myinfo.apple.com. You can also create an Apple ID or reset your password from this webpage.

    *Ensure that your date, time, and time zone are set correctly. If your country has recently made a daylight saving time (DST) change, it may be necessary to manually set the time zone to one that matches your local time.

    *Check that your email address is verified in Settings > Messages > Receive At.
    ******If Settings > Messages > Receive At shows your email status as "verifying," follow the instructions in the verification email that was sent to complete the process.
    ******Toggle iMessage off and on in Settings > Messages.

    *iPhone automatically registers your phone number for use with iMessage during activation. If you encounter issues activating or using iMessage with your phone number:
    ******Verify that you are connected to a cellular network.
    ******Toggle iMessage off and on in Settings > Messages.

    If you are unable to activate iMessage on a device after remote wiping it, wait at least 24 hours and try again.
     
  10. macrumors 6502a

    Joined:
    Oct 6, 2009
    Location:
    Minnesota
    #10
    worked for me. thanks a lot.
     
  11. macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #11
    What ya can do is restore from the last back up which activated imessage and facetime!
     
  12. macrumors regular

    Joined:
    Jun 20, 2012
    #12
    unified messaging on MBA running Mountain Lion GM

    Has anyone gotten iMessage to register their phone number in iMessage on a Mac running Mountain Lion???
     
  13. macrumors newbie

    Joined:
    Jan 28, 2010
    #13
    Yup. Tried that. Still didn't work. :/
     
  14. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #14
    No idea then. The developer forum was not much help when I looked there.
     
  15. thread starter macrumors regular

    Joined:
    Jul 12, 2012
    Location:
    GA
    #15
    Well I finally found a copy of the beta 3 ipsw file to download through a torrent. Restored to my last 5.1.1 backup and then updated to beta 3 using the non-dev trick. It installed fine with no problems and my iMesaage is working fine now. Only thing I have noticed now is it feels like the snappiness I had come to love from iOS 6 compared to iOS 5 is now gone and feels about the same a iOS 5. Also the phone gets hot now when I am playing CSR Racing just like when I am using heavy GPS. Never noticed it getting this hot before even on iOS 5 just playing a game. Hoping this clears up by intself in the next day or two.
     
  16. macrumors 68030

    Tinmania

    Joined:
    Aug 8, 2011
    Location:
    Aridzona
    #16
    Reset Network Settings worked for me!

    I had the exact same issue as the OP.



    Michael
     
  17. macrumors regular

    Joined:
    Oct 6, 2008
    Location:
    Massachusetts
    #17
    Reset network settings worked for me after the second reset. Turn iMessage off. Reset Network settings. Turn it back on and it worked. Only thing is now I can't access Facetime over cellular. I'm getting the contact ATT popup which sucks. I pay for my data, let me use it as I want.
     
  18. macrumors 6502

    Joined:
    Nov 12, 2007
    #18
    This worked for me too. The ATT popup is new with beta 3, can't be fixed for now.
     
  19. macrumors 68000

    Joined:
    Jun 2, 2006
    #19
    i changed my sim card to another number, now facetime and imessages keeps on waiting for activation and my old number still there. :mad:
     
  20. macrumors 6502

    Joined:
    Jul 24, 2011
    Location:
    Sweden
    #20
    Bump
     
  21. macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #21
    Some things to try:

    -Toggle iMessage On/Off
    -Swap to a different SIM and then back again
    -Keep Waiting
    -Restart the phone

    This issue can be difficult to solve.
     
  22. macrumors 68030

    Tinmania

    Joined:
    Aug 8, 2011
    Location:
    Aridzona
    #22
    I have not been able to register my phone number in the Messages app in Mountain Lion--it only accepts email addresses for "you can be reached for messages at." However, my conversations--even the ones I have started from phone number on iPhone--seem to be coming over OK.

    One person's conversation in particular (who was confused when getting separate conversations--so I only used phone number) now is showing up in Messages on the mac. I have not heard a complaint from her so I am assuming it is working with my phone number.

    It appears I can continue phone-number-based iMessage conversations on my Mac but connect start a new one from there.

    Since ML is GM I don't see phone number specifically added to the Messages app anytime this summer.



    Michael
     
  23. macrumors 6502a

    Zorn

    Joined:
    Feb 14, 2006
    Location:
    Ohio
    #23
    This showstopper bug still exists for me. Anytime I turn on iMessage my contacts are all confused as to why my email address is texting them. I cannot make it come from my number. Tried network settings reset, DFU restore, everything. It just never ever activates. Anyone else running into this? Beta 3 is a complete effing mess.
     
  24. macrumors 68030

    Tinmania

    Joined:
    Aug 8, 2011
    Location:
    Aridzona
    #24
    Try resetting network settings.




    Michael
     
  25. macrumors newbie

    Joined:
    Dec 7, 2011
    #25
    Finally worked for me

    I had to reset the network settings twice.
     

Share This Page