iMessage with both iPad and iPhone.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Soundburst, Oct 11, 2011.

  1. macrumors 6502a

    Oct 4, 2006

    I have an iPad and iPhone.

    Right now my friend is I messaging me from her iPhone to my iPad by having my address stored in my contact details of her phone.

    My other friends can iMessage my iPhone because my number is stored in their phone. . .but do they ALSO have to store that email address in my contact name if I want to receive their iMessage messages on my iPad?

    Or does Apple know that this iPad is linked to the same Apple I'd as my phone and thus I don't need to have my email address stored on all my friends phones :)
  2. macrumors 6502a

    Sep 17, 2008
    The latter. You can set up "receive at" addresses in Messages Settings. Obviously, you can't add your iPhone number, but the Apple will know.


    No wait, I'm wrong.

    for it to show up on both, you need to send it to the e-mail address. A friend texted me on my iPhone number and it didn't hit my iPad.
  3. thread starter macrumors 6502a

    Oct 4, 2006
    So we should tell all our friends to add our email address to our contacts and then we're sorted?
  4. macrumors 6502a

    Sep 17, 2008
    Yeah, that's probably best.
  5. macrumors 6502a


    Apr 24, 2010
    I have an iPhone and iPad as well. The only way I could get iMessages to appear on both was to have the person text to the iMessage address I set up.

    When my girlfriend texts to my iPhone phone number, it still appears as an iMessage, but my iPad does not receive it ... even though my contact information in her iPhone has the iMessage email address. For iMessage to work across multiple devices you have to message the email address not the phone number.
  6. macrumors 68000

    Jun 5, 2009
    can random people send me an iMessage if I were to post my iMessage email address somewhere, or will I have to add them to my contacts first?
  7. macrumors 6502a

    Sep 17, 2008
    There is no confirmation on your side.
  8. thread starter macrumors 6502a

    Oct 4, 2006
    How do they message the email. . .:S I thought iMessage just detected whether there was 3G or wifi and sent it . . .you can just click a name in iMessage. . .you can't specify the actually number can you ?
  9. macrumors 6502a

    Sep 17, 2008
    When you use iMessage on your iPhone, and create a new message you start typing in your contact info a-la Mail. If the contact registers as an iMessage contact the send message button will be blue. If it's needs to use SMS it will be green.

    Using the phone number will only get it sent to an iPhone. The 3g or WiFi isn't relevant; the device needs to have an actual phone number to receive a message sent to a phone number.

    So, to ensure you get the iMessage to all iOS devices you need to use the Apple ID since that's the one contact info piece all devices have in common.
  10. thread starter macrumors 6502a

    Oct 4, 2006
    Ah so I'll tell my friend when they message me to select my apple I'd when sending me a message for the first time :)
  11. macrumors newbie

    Oct 13, 2011
    A fix for iMessage caller id


    My Email showed up onmy friends iPhone when I used iMessage. So he placed my email under my name in his contacts, so when i imessage my name shows. But when he messages me he had to select my email to for imessage to work.

    The Fix:

    So I had him delete my contact and re enter it with just my number, then he text me over the cellular network and I text him back(both had wifi on also). After this his phone recognized my number as an iMessage number and the problem was solved. Now we both see eachothers name instead of him seeing my email when recieving and selecting email for sending.
  12. macrumors newbie

    Mar 10, 2011
    I might have figured it out

    I was having the same troubles, I could send iMessages via my iPad 2 but when I get a message back I could only view the response on my iPhone 4S. I was checking this forum and was trying to figure out why. I since sent myself an iMessage from my iPad and got a response from myself on my iPad then tested it with my friend and could send and receive messages on the iPad and the threads were viewable on my iPhone as well like magic. try it out see if it works for you.
  13. macrumors newbie

    Oct 17, 2011
    What if I don't want my iMessages to be both on my iPad and my iPhone

    My iPhone is mine only and my iPad is a shared device. Is there a way to be certain the iMessages I wanna keep private dont show up on the iPad???

    Isn't there an on/off switch of some sort?
  14. macrumors 68020


    Jul 11, 2007
    Torrance, CA
    Yes. Go to Settings /Message and turn it off. Also make sure send Messages to you phone number.
  15. macrumors newbie

    Mar 10, 2011

    I don't think so. you can turn iMessage off or change the apple ID linked to the iMessage account. otherwise it goes to the cloud and goes to all devices.
  16. macrumors newbie

    Mar 10, 2011

    go to settings-> messages->receive at->caller ID select the Apple ID on all devices (yes even the iphone) and all messages will sync or add your apple ID if its not already there
  17. macrumors newbie

    Aug 27, 2010
    messages won't go to iphone

    I've done everything that you all have suggested and messages sent to my apple ID still do not come to my iphone. They do come to my ipad, but not phone. HELP.
  18. macrumors newbie

    Feb 3, 2012
    This is what worked for me

    On my iPhone: I changed my receive at to just my phone number and the address and everything worked. When someone now sends a message to it comes both on my iphone and iPad.

    FYI: My icloud account is set with a different email address other than my which is set as an alias.

    Hope this helps.

Share This Page