iMessages shows my email address instead of phone number

Discussion in 'iOS 5 and earlier' started by ajayvarma87, Oct 17, 2011.

  1. ajayvarma87
    Expand Collapse
    macrumors member

    Joined:
    Jun 22, 2009
    #1
    Hi,

    I upgraded to a iPhone 4S and I also got a new microsim. The upgrade process didnt go as smoothly and I had to get my data tariff re-added. I have my data working now but when I send a iMessage, it displays to the recipient as my email address instead of my phone number. I have removed my email address from my contact details, switched iMessages on and off, done a hard reset. But its still coming up as my email address.

    Has anyone experienced this or know how to solve this? When I say my email address, its my apple ID i mean.


    Thanks Guys
     
  2. Zincous
    Expand Collapse
    macrumors 6502

    Joined:
    Nov 21, 2008
    Location:
    Sacramento CA
    #2
    Settings > Messages > Receive at > Caller ID

    And you can choose to display your phone number or apple ID.
     
  3. litchblade
    Expand Collapse
    macrumors member

    Joined:
    Sep 4, 2011
    #3
    It's also possible for the receiver to enter your email address to your contact details, so he will only see your name then.
     
  4. ajayvarma87
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jun 22, 2009
    #4
    Thank You!!!!!!!!! I had to remove my apple ID! Thankssss
     
  5. Zincous
    Expand Collapse
    macrumors 6502

    Joined:
    Nov 21, 2008
    Location:
    Sacramento CA
    #5
    No problem :) Glad that worked.
     

Share This Page