iMovie '09 G4 Hack?

Discussion in 'Mac Applications and Mac App Store' started by checkmac, Jan 28, 2009.

  1. macrumors newbie

    Joined:
    Jan 28, 2009
    #1
    i used one of these hacks/patches for my imovie 08, to make it run on my G4 Powerbook 1.33GHz. but now i have imovie 09 and can not find a hack, a patch, nor instructions on how to hack or patch it...can someone help? i (and im sure, many others on G4s) would be greateful
     
  2. macrumors newbie

    Joined:
    Jan 30, 2009
    #2
    I Did It!

    position:NEW value
    15fb9c: 4E 80 00 20
    15fc7c: 4E 80 00 20
    15fe00: 4E 80 00 20

    use HexEdit (or another hex editor) to jump to the position and replace the values with newer ones (4E 80 00 20). Remember to backup original app before doing any change ;)
     
  3. macrumors member

    Joined:
    Jan 30, 2009
    #3
    Ok good but how do we INSTALL iMovie 8 to change this code within iMovie???
     
  4. macrumors newbie

    Joined:
    Jan 30, 2009
    #4
    Simple :) Copy iMovie.pkg in a writable place and open with TextEdit (it's a simple text file) this file inside the pkg: iMovie.pkg/Contents/iMovie.dist .
    Now comment out (place a // at the beginning) every line inside function installationCheck() execpt one single return true; .
    Save and proceed to install :)
    Remember to install AppleIntermediateCodec.pkg if isn't already installed because is required for iMovie to work properly.
     
  5. macrumors member

    Joined:
    Jan 30, 2009
    #5
    Alright, so, once installed, we would go to the MacOS file for iMovie (exec) and find these "Hex or ASCP?" values and replace them?
     
  6. macrumors member

    Joined:
    Jan 30, 2009
    #6
    Thank you , thank you! You got it first ranauei. I got it working on a G4! Kudos to you my friend.

    Now I just have to worry about these stupid Garageband music lessons now....lol
     
  7. macrumors newbie

    Joined:
    Jan 31, 2009
    #7
    hi!

    i tried this but i can't make it work... it crashes after i make the changes.

    here's how i do it...

    1. open HexEdit and find the iMovie executable file in MacOS folder inside the iMovie Package and I select "Auto" on the Open menu.
    2. then i use Find&Replace the strings you said in "Hex" mode and change them with the new ones.
    3. i go to file menu, and i "Save" and exit HexEdit.

    then i launch iMovie and it crashes :(

    could you please help me?

    thanks a lot!
     
  8. macrumors newbie

    Joined:
    Jan 30, 2009
    #8
    You don't have to do find&replace. Instead simply use Find -> Go To Address... and in this dialog select Hex and insert the hex address provided (the position).
    Now you have the cursor at the beginning of 4 groups of 2 digits (7C 08 02 A6) replace this group with new values provided (4E 80 00 20).

    So in other words only 3 entries, at the provided positions, of 7C 08 02 A6 must be replaced with 4E 80 00 20
     
  9. macrumors newbie

    Joined:
    Jan 31, 2009
    #9
    thank you a lot!

    i've done it!
    well, what i was doing wrong it was that i didn't delete the "strings" at that location, i just typed it. then i realized that i had to delete what was there and then type the substituting code!

    :):)
     
  10. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #10
    I followed the above instructions and iMovie is crashing. I opened the file in HexEdit, went to the address, hit the delete right key 8 times and put in the new values for each one and then saved. Is there anything I'm doing wrong?
     
  11. macrumors newbie

    Joined:
    Jan 31, 2009
    #11
    hi,

    it's not 8 times... when you hit delete, it deletes 2 blocks at the time... so you'll have to delete 4 times only!
     
  12. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #12
    D'oh, it's working now, thanks! :)
     
  13. macrumors newbie

    Joined:
    Jan 31, 2009
    #13
    nice :)

    it runs pretty well on my PB 1.33Ghz!
     
  14. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #14
    Video with effects is a bit laggy on my 800MHz iMac but it seems to be running as well as 06 and 08 were :D
     
  15. macrumors newbie

    Joined:
    Feb 1, 2009
    #15
    imovie 09 patch for G4

    Hallo,

    i am not into programming. i tried, but i can not get it work.
    can anybody place the imovie exec file to download it?

    if this doesn´t work, please place a step4step tutorial. if posible with pictures or instruction movie.

    thanx a lot.
    all the best from cold germany

    robokoepp:confused:
     
  16. macrumors newbie

    Joined:
    Jan 31, 2009
    #16
    hi,

    here's my modified executable file for iMovie:

    http://tinyurl.com/imovie09G4

    you have to:

    1. unzip the file i uploaded
    2. select iMovie app you installed, right click and choose "Show Package Contents"
    3. go to Contents/MacOS/
    4. replace the iMovie executable file there with the one you unzipped
    5. run iMovie!

    tell if it works.
     
  17. macrumors member

    Joined:
    Jan 30, 2009
    #17
  18. macrumors newbie

    Joined:
    Jan 31, 2009
    #18
    hi,

    i don't have a MobileMe account... so i can't test it! sorry!
     
  19. macrumors member

    Joined:
    Jan 30, 2009
    #19
    (Bump) iMovie 8.0.3 powerpc hack

    Can anyone confirm that these hex edits are false?

    "For iMovie 8.0.3:
    Position: New value
    16bf0c: 4E 80 00 20
    16bcec: 4E 80 00 20
    16bc0c: 4E 80 00 20"

    I use hexedit to go to these offsets and replace these values. Credit to RunAway for these edits but they aren't working for me. This is the only post I found so far on values for 8.0.3
     
  20. macrumors member

    Joined:
    Jan 30, 2009
    #20
    (Bump)

    Can anyone confirm these offsets for 8.0.3 on g4?
     
  21. macrumors newbie

    Joined:
    Aug 16, 2009
    #21
    Thanks for this - and it works!!!

    I'd done some work with the hacked iMovie 8.0.2 a few months ago, but it seems that the 8.0.4 update killed it on my G4 SP 1.25 MDD.

    The HexEdit changes I made to an 8.0.4 copy didn't work properly for some reason.

    Thanks for making the now working 8.0.4 'upgrade' so much easier.

    Patrick
     
  22. macrumors newbie

    Joined:
    Jan 29, 2013
    #22
    Another way to get iMovie on Powerbook G4

    This is what you can do if the above doesn't work.

    Step 1: Drag the iMovie 09 pkg onto the desktop.
    Step 2:download the Program Pacifist. Here's the link: http://www.charlessoft.com/
    Step 3: Once Pacifist is installed drag the iMovie pkg into Pacifist's main window. It should load on.
    Step 4: Click install on the upper left hand corner of Pacifist.
    Step 5: Once installed to your computer, open up the Terminal Application.
    Step 6: Copy and paste the command bellow into Terminal:

    defaults write NSGlobalDomain allowG4Launch-bool Yes

    And then open up iMovie.

    Note: You must have Quicktime 7.6.

    If you have any questions ask me.
     

Share This Page